Support » Plugin: Hide My WP Ghost - Security Plugin » Not hiding urls of Fast Velocity Minify’s minified files

  • Resolved fijisunshine

    (@fijisunshine)


    Great plugin!

    In premium HMWP, I noticed that when using it with Fast Velocity Minify, the urls associated with the minified css and js files aren’t hidden by HMWP.

    For example, one of my minified js files in the source code shows /wp-content/uploads/…

    Could I be doing something wrong? Or, can you give a code snippet for htaccess that would block the directory associated with these cache files? Or, are there other minify plugins that work fully with HMWP?

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    I will check the plugin and see if I get the same issue.

    Have you tried to switch on Hide My WP > Advanced > Late Loading?

    This feature will let the cache plugin to load first and to change the URLs before the cache plugin saves the code in files.

    Let me know if this solution worked for you.

    Best,
    John

    Hi John,

    Thanks for your quick response. Yes, I had tried late loading but it didn’t seem to have an impact on Fast Velocity Minify’s minified files.

    Some additional info that may help you: /wp-content/uploads/ is hidden in the source code url for the minified css and js files in the header, but not for the js file in the footer.

    Hiding more of these urls than just /wp-content/uploads/ part would be ideal, but at least hiding /wp-content/uploads/ in footer would be great.

    Thanks again!

    Hi,

    Yes, all the paths should be hidden in the source code.

    No worries, I will test the plugin and come with an update soon.

    Best,
    John

    Hi,

    I checked the plugin with different settings and all the paths were changed in source code.

    Have you tested your website with a different browser?

    You can send us the Fast Velocity Minify plugin settings at contact@wpplugins.tips and we will try with the same configuration as you.

    John

    Thanks for checking, John. I verified the issue in a few browsers. I’ve tried many settings in Fast Velocity Minify but without luck.

    Do you have a minified js file in the footer when you test and its path is hidden? I’m using HMWP PRO v3.0.038, did you test with this version? I’m also on multisite, are you? Thanks again

    Hi John,

    The issue is resolved and was unrelated to HMWP. Your plugin works great! Thanks again for the helpful responses!

    Awesome. Glad you find the solution.

    Best,
    John

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.