WP Facebook Open Graph protocol
[resolved] Not grabbing correct description (4 posts)

  1. brettr
    Posted 2 years ago #

    I have a meta description for this post http://www.bitesizebschool.com/blog/how-to-know-when-youll-earn-your-first-dollar/ but the og:description is grabbing a code snippet within the post instead. Do you know what is wrong?


  2. Chuck Reynolds
    Plugin Author

    Posted 2 years ago #

    well because 1 you're not using a seo plugin to give a specific meta description that I can see (maybe doing it statically in your template?) and 2 the first thing you have in the post/page content is

    <style type="text/css">
    .calculatebutton {margin-left:350px;}
    @media (max-width : 480px) {
    .calculatebutton {margin-left:0;}

    Solution A: use an SEO plugin to put out a good meta description
    Solution B: take css out of the body content

  3. brettr
    Posted 2 years ago #

    Thanks. I moved the CSS further down into the body since it is only used on this page. Now the description displays and the FB debugger reports no errors.

    I have another question about this same post. I've read the g+ will use OpenGraph just like FB. But it doesn't pick up the description when I post as a "link". Do you have some idea about that?

  4. Chuck Reynolds
    Plugin Author

    Posted 2 years ago #

    G+ doesn't do exactly what FB does but they say they'll use open graph tags as a fallback if the G+ specific xml isn't there.

    See here: https://developers.google.com/+/web/snippet/

    G+ doesn't have (that I know of) a cache control like FB's debugger so maybe it's not showing a desc because it's cached or idk. Google+ is a whole other beast. If you want very specific control over the way G+ handles your post you should look into tagging your page with schema.org protocol.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Facebook Open Graph protocol
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.