Support » Plugin: User Submitted Posts » Not getting email notifications of submissions

  • Resolved Trishah

    (@trishahdee)


    Your plugin is submitting the information as a pending post but is not sending the notification email about the submission. I know the site is sending emails because I have another plugin that sends notifications whenever someone logs in. l have tried adding the two emails with and without a space after the comma. I have checked my junk and trash folder in my email.

    What do you think could be the reason?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Thanks for reporting this. It looks like a bug with email alerts not getting sent to the user. I will investigate further and get this fixed up for the next plugin update.

    Trishah

    (@trishahdee)

    Thank you! Please let me know when it’s fixed.

    Hello. Do you have a fix for this yet?

    Plugin Author Jeff Starr

    (@specialk)

    Not yet, definitely working on it though. Thank you for your patience.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this! I figured out why emails were not sending to the user, because that is not currently a feature of the plugin. In the free version of USP, email alerts are sent only to the administrator. Really sorry about any confusion this may have caused, was a total brain burp.

    Trishah

    (@trishahdee)

    Thank you for the reply, Jeff. However, you misunderstand. I realize that the admin is suppose to get the notification emails. What I am say that no one, not even the admins, are receiving the notification emails.

    Plugin Author Jeff Starr

    (@specialk)

    Understand, sorry for the confusion. I just did a bunch of testing for email alerts, and the admin alerts are working fine. If that is not happening on a specific site, something is interfering with normal functionality (could be another plugin, theme, server settings, spam, the list goes on. So my best advice is to do some basic troubleshooting to determine the cause of the issue. I know there are many variables involved with sending/receiving email, so I would be glad to send a free troubleshooting guide if it will be useful for you.

    docthomas

    (@docthomas)

    I am also seeing this issue. I have configured the notifications settings for this plugin but the account that is listed as an administrator does not receive any email notification. Not my user account is NOT named admin, but it does have an administrator role. I am not sure if your plugin looks for a user account named admin or if it picks it by user role.

    Is there a log I can review for the actions of the plugin to help troubleshoot this issue?

    Plugin Author Jeff Starr

    (@specialk)

    @docthomas Glad to help but no there isn’t an action log or similar. The best I can recommend while waiting for the next update is to check your site’s debug/error log to see if there are any errors happening.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.