Support » Fixing WordPress » Not getting confirmation email to change admin email address in General Settings

  • Resolved frankg26

    (@frankg26)


    Hello all,

    I have to change the main email address in General Settings for admin purposes. However, I have yet to receive the confirmation email I have tried four times.

    Anybody else having this issue?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi @frankg26,

    Having that issue, I’d try the following:

    1) Check the spam inbox in case the email went there.
    2) If it was not found above, then I’d contact your hosting provider about it in case emails are disabled in your website.
    3) If the above doesn’t work, I’d open the database, and I’d go to the table wp_users and I’d edit the email address of the user with ID 1, but please only do that after doing a backup and if you have the experience of handling a database.

    Hope this helps!

    frankg26

    (@frankg26)

    Hello @_dorsvenabili Thanks for your reply, I did not get a push notification. Hence I never got to read this message until just now. I will take a look.

    • This reply was modified 1 year ago by  frankg26.
    frankg26

    (@frankg26)

    It has been fixed! I had to set up SMTP with the WP Mail SMTP plugin

    Linda Lee

    (@wptotaltraining)

    Not receiving confirmation email to change admin email address
    This is not resolved. and this thread is locked.
    https://wordpress.org/support/topic/not-receiving-confirmation-email-to-change-admin-email-address/

    I have been using WP for 12 years and run over 200 sites for clients and recently this is not working anymore. Why is WP not looking into it. I am on the same host and nothing has changed and my clients are not getting the notifications. When I set up new sites I put myself as the general admin until I launch the site. Then I change it to the new owner. For the last 6 months or so this has NOT been working. What is going on with it?

    I found a workaround. Go to this link: https://yourdomainname.com/wp-admin/options.php. (just copy and paste- apparently you can’t find this page any other way) Do a search for the old email (the one you are ditching) and replace with your new one. Save. Now you don’t need the email confirmation.

    mistressladywednesday

    (@mistressladywednesday)

    Hi,

    I am having the same issue right now.

    This issue says resolved at the top of the thread, but I see no solution.

    And no, I am not going to open the database to make changes.

    This is ridiculous.

    lukewilson6

    (@lukewilson6)

    technicalcat (@technicalcat)
    3 weeks ago
    I found a workaround. Go to this link: https://yourdomainname.com/wp-admin/options.php. (just copy and paste- apparently you can’t find this page any other way) Do a search for the old email (the one you are ditching) and replace with your new one. Save. Now you don’t need the email confirmation.

    THIS WORKS! Thanks for providing the solution to this issue 🙂

    Changing the options.php file isn’t working for me. I can go to the page and enter the new info, but when I try to save the changes, I get the following error:

    412 Error
    Your request got filtered out due to possible security issues.
    
    One or more things in your request were suspicious (defective request header, invalid cookies, bad parameters)
    
    If you think you did nothing wrong:
    
    try again with a different browser
    avoid any evil characters inside the request url
    If you are the owner of the website, you can consider revising the rules of the mod_security module or turning it off from your Web Hosting Control Panel.

    Changing permissions on the file doesn’t seem to help.

    I’ve updated the correct entry in the database. Note to @_dorsvenabili above: You need to edit the admin_email in the yourdatabaseprefix_options and/or entry #1
    in the yourdatabaseprefix_users tables, not the wp_users table. The last is used for structuring the WP admin fields, not for storing actual user info).

    I changed the wp admin email to a gsuite one by going to
    https://yourdomainname.com/wp-admin/options.php.
    But I’m still not receiving email from wordpress on to my gsuite account 🙁

    I’m having this same issue. If I change the WP admin email to any of my other email addresses…I get the confirmation email. If I change it to my GSuite email, it is not being delivered. I’ve reached out to GSuite and they confirmed that there is not an issue on their end. How can this be resolved?

    Has anyone resolved this issue? I have just encountered the same issue!!!

    I’m also having this issue. I tried changing the admin email address, and it says an email has been sent to me, but nothing comes to my inbox or spam. I’ve checked to see if emails are being blocked, by nothing shows in the quarantine folder either. Has anyone resolved this yet?

    MrsJessicaSimpson

    (@mrsjessicasimpson)

    My twopence worth, .. for what’s it’s worth.

    Same as the above, but I’m working locally on a test rig developing a theme.

    I’ve edited the PHP.INI file to include the ‘extension=php_openssl.dll’ aspect, and that at least has enabled ‘WP MAIL SMPT’ to send test messages, but as yet: the WordPress core system itself won’t send me these emails .. really frustrating.

    Been searching Google, and this weird issue appears to be common: with most users simply either ignoring it, or using the http/(your site url)/wp-admin/options.php method to force the change through.

    BTW: Horrified by what’s actually in the options screen. And yes: I could possibly change the admin email there, but even on a test site: (with backups), I really don’t want to touch that aspect of my installation.

    Been scratching my head over this for a week now, and I’m no closer to finding a cure; other than suggesting that it’s a hosting issue, but there again: I can’t find what’s stopping the emails being sent in my Apache config file.

    Hope someone with better detection skills can point us in the right direction, cos this useless detecting detective has drawn a blank.

    Rgds – Jessica.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.