Support » Themes and Templates » [Resolved] Not getting a 4×4 grid

[Resolved] Not getting a 4×4 grid

  • Hey

    For some reason I’m not getting a 4×4 grid with pictures on the home page.

    Instead I’m getting a grid that looks something like this.

    * * * *
    * * * *
    * * * *
    * *

    Any ideas on how I can fix this?

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have very same problem. Any ideas how to fix it?

    I tried to look into the code but could not find where is something wrong.

    First Post ever! 😀

    I had the same problem. It’s not the grid, its the number of post items per page. Set it to some higher value, or a value divisible by 4, like 16 post per page.

    This you can achieve by going to the dashboard menu -> Settings -> Reading , and then change the value of “Blog pages show at most”. If you want a 4×4 grid this would be 16, 5×4 grid is 20 etc. etc.

    Hope this helps,

    Thank you!

    thanks! it’s working!!!

    It didn´t worked for me.

    If I set to 16, it gives me this kind of grid. I´ve tried everything!


    Do you have any suggestion on how to fix this?

    actually it is showing like this:


    could you please give adress of your page?

    hmz, i had same problem at first, but i did 12 (4×3) grid and it worked fine for me. because with 16 – there was the same problem for some reason

    Thanks for the reply Zhiu

    I also tried setting to show 12 posts at main page but it still breaks the grid.

    The bug I’ve discovered is that if the number of posts published is multiple of 4, the grid works. Right now I have 41 posts published, for it to work I would have to create/publish 3 posts more to achieve 44 posts. It shouldn´t be like this.

    Do you have any suggestion?

    This thread is not Resolved, I dont know why they marked as a Resolve item since nobody answered my last question.

    I still have a BIG problem with the main page grid. The solution provided here doesn’t work for me.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Not getting a 4×4 grid’ is closed to new replies.