WordPress.org

Ready to get started?Download WordPress

Forums

Snaps
[resolved] Not getting a 4x4 grid (12 posts)

  1. repsak
    Member
    Posted 1 year ago #

    Hey

    For some reason I'm not getting a 4x4 grid with pictures on the home page.

    Instead I'm getting a grid that looks something like this.

    * * * *
    * * * *
    * * * *
    * *

    Any ideas on how I can fix this?

  2. zhiu
    Member
    Posted 11 months ago #

    I have very same problem. Any ideas how to fix it?

    I tried to look into the code but could not find where is something wrong.

  3. ScorpionWins
    Member
    Posted 11 months ago #

    First Post ever! :D

    I had the same problem. It's not the grid, its the number of post items per page. Set it to some higher value, or a value divisible by 4, like 16 post per page.

    This you can achieve by going to the dashboard menu -> Settings -> Reading , and then change the value of "Blog pages show at most". If you want a 4x4 grid this would be 16, 5x4 grid is 20 etc. etc.

    Hope this helps,
    Cheers!

  4. repsak
    Member
    Posted 11 months ago #

    Thank you!

  5. zhiu
    Member
    Posted 11 months ago #

    thanks! it's working!!!

  6. Manoel
    Member
    Posted 5 months ago #

    It didn´t worked for me.

    If I set to 16, it gives me this kind of grid. I´ve tried everything!

    ****
    ****
    **
    **

    Do you have any suggestion on how to fix this?

  7. Manoel
    Member
    Posted 5 months ago #

    actually it is showing like this:

    ****
    ****
     **
    **
  8. zhiu
    Member
    Posted 5 months ago #

    could you please give adress of your page?

  9. Manoel
    Member
    Posted 5 months ago #

  10. zhiu
    Member
    Posted 5 months ago #

    hmz, i had same problem at first, but i did 12 (4x3) grid and it worked fine for me. because with 16 - there was the same problem for some reason

  11. Manoel
    Member
    Posted 5 months ago #

    Thanks for the reply Zhiu

    I also tried setting to show 12 posts at main page but it still breaks the grid.

    The bug I've discovered is that if the number of posts published is multiple of 4, the grid works. Right now I have 41 posts published, for it to work I would have to create/publish 3 posts more to achieve 44 posts. It shouldn´t be like this.

    Do you have any suggestion?

  12. Manoel
    Member
    Posted 3 months ago #

    This thread is not Resolved, I dont know why they marked as a Resolve item since nobody answered my last question.

    I still have a BIG problem with the main page grid. The solution provided here doesn't work for me.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.