Support » Plugin: Simply Static » Not generating ZIP file

  • mike

    (@miquelalexandrmunoz)


    I am having a problem and can’t get the plugin to generate the zip file it runs a couple of minutes and then the page goes blank and stops working (no matter how long you wait it stops running).
    Could it be that the page is too heavy? When I first downloaded the plugin I had no problem and it generated the zip file perfectly but since I’ve added content to the page it doesn’t work.

    The url is mike-english.com

    If you need any additional info please let me know.
    I am not experienced so it could be an error in some configuration, etc.
    Thank you in advance for any help.

    https://wordpress.org/plugins/simply-static/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    Sorry for the trouble you’re encountering. It sounds like it’s taking Simply Static so long to generate a static copy of your site that your server is cutting off the process prematurely.

    If you have control of your server (i.e. it’s a VPS) then you can try adjusting the timeout in your php.ini file. In the more likely event that you’re using some kind of shared hosting, I’m afraid there’s not much you can do at the moment. I’m going to be working on a way around this limitation for larger sites, but that fix is still a ways out; my apologies.

    Hi,
    I am experiencing the same issue.

    Can you please let us know which setting in the php.ini file need adjusting to prevent the timeout.

    thanks!

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    The setting is called max_execution_time. And a heads up, Apache and nginx can have timeouts of their own for long-running scripts. If adjusting that value and reloading/restarting the server doesn’t work, you may need to look there as well.

    Thanks, I will give it a shot, let you know how it went.

    hello same here

    I am with one.com and no possibilities to touch eht PHP.ini any other idea on how to do this ?

    ben

    Try adding this in your wp-config.php file guys…

    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    define( 'WP_MEMORY_LIMIT', '96M' );

    Feel free to change the numbers

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Thanks for the tip, poopshoot!

    bbenelux- If the above tip doesn’t work, the next major update that we’re working on will fix this issue. The current ETA for that release is by the end of February.

    I have a similar problem in that I cannot access the zip file that is generated but as you can see from a copy of my activity log below, the process is not timing out. This is the first time I have used the plugin with the default settings.

    [2016-07-16 03:18:07] Fetched 5634 of 5634 pages/files
    [2016-07-16 04:03:05] ZIP archive created: Click here to download
    [2016-07-16 04:03:06] Wrapping up
    [2016-07-16 04:03:10] Done! Finished in 00:45:05

    The log looks fine but when I “click here to download” it says file not found: http://xxxx.org/wp-admin/admin.php?simply-static_zip_download=simply-static-1-1468639085-superasc.zip

    (I replaced the site name in the above URL with xxx for security reasons).

    Seeing a similar issue on a site I’ve set up. Server is running Ubuntu, PHP 5.5.9-1; have updated to latest WP (4.5.3). I’m running on a test installation, with multiple different sites; I’ve created a simple site with only 3 pages, which seems like it should be a quick and simple download, but no luck.

    The page doesn’t go blank like in the OP’s description; it just gives the following under Activity Log:

    [2016-07-20 21:59:41] thadboyd has started generating static files
    [2016-07-20 21:59:41] Setting up
    [2016-07-20 21:59:41] Fetched 30 of 30 pages/files

    And then the progress spinner next to the “Pause” button spins forever. If I reload the page, I get the Resume/Cancel buttons and an Export Log with a list of the 30 files. The first two lines (the root page and wp-includes/js/wp-emoji-release.min.js) show “—” in the “Found on” column, and there are three pages with 400-series errors (xmlrpc.php, comments/feed, and wp-json/oembed/1.0/embed); other than that everything looks normal.

    I’ve tried disabling all other plugins, changing max_execution_time from 30 to 120, and adding the two lines to the end of wp-config.php that poopshoot recommended. No change; the issue persists.

    Let me know if you have any other ideas; thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Not generating ZIP file’ is closed to new replies.