Support » Plugin: Contact Form 7 » Not functioning properly with WP 3.9

  • Resolved ButterflyHerder


    Greetings! We just upgraded a client website to WP 3.9 and have been testing the plugins to make sure everything works properly.

    The Contact Form 7 is NOT functioning well. I have disabled ALL other plugins, and even switched to the “generic” Twenty Fourteen theme. After hitting the ‘submit’ button, it spins & spins, and never actually sends the message.


    Please assist. Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Just FYI… it’s 43 minutes later, and the “spinner” is still going in circles. The message has yet to get sent.

    We are having trouble as well. It worked flawlessly for ages until the last update.

    Same behavior: click send and the “working” spinner appears but nothing happens. The confirmation page is not shown. However, I have confirmed that if the “to” address is local to the server the mail is delivered. I am trying to confirm receipt at a remote address.

    Update: I tried creating a brand new contact form… still doing the same thing. Not working.

    We need to get this site up & running. I can’t wait any longer.

    So, I’ve created a “test” page with your contact form. You can try using it there to see what I’ve been talking about. I am removing it from our main contact page.

    Please DO continue to trouble-shoot this issue. We really like your plugin and want to continue using it.

    TESTING Contact Form

    Plugin Author Takayuki Miyoshi


    Try deactivating all other plugins and switching to the default theme.

    I found this message at the bottom of HTML source of the page.

    <!– WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! –>

    Hi there –

    If you would’ve read through my posts, I have ALREADY disabled all the plugins, switched to the 2014 theme… in addition to trying the 2012 and 2013 themes.

    Nothing is making your plugin work.

    I had to re-activate everything so my client could post on her blog.

    If you’re willing to trouble-shoot with me, I can disable it again. But I can’t just leave it that way unless we are working on it.

    By the way, Super Cache is disabled. I don’t know why that’s showing up. It’s not turned on.

    Having the same issue, constant spinning and no delivery but it’s only happening in my footer widget, not on my pages.

    @mophilly & @mia2014

    As per the Forum Welcome, please post your own topic.

    Posting in an existing topic prevents being able to track issues by topic. Added to which, your problem – despite any similarity in symptoms – is likely to be completely different.


    WP Super Cache is a known issue reported several times in this forum – apparently the WP Super Cache plugin is not fully removed when deactivated and creates an ongoing error.


    @buzztone… You got it! BRILLIANT!

    I had NO IDEA that just the presence of the plugin’s files would affect the functionality of our site, even though it was disabled. Once I eliminated the files and removed the code that had been added to wp-config.php, everything started working PERFECTLY.

    This is a good lesson and something I will remember going forward as I trouble-shoot other projects.

    THANK YOU! 🙂

    @buzztone my issue is precisely what the original poster wrote. We do not use wp_super_cache. the problem with sending mail from Contact 7 remains.

    Thanks to the Contact Form 7 team for finding the problem. Version 3.8.1 resolves the problem on our sites.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not functioning properly with WP 3.9’ is closed to new replies.