Support » Plugin: WordPress Infinite Scroll - Ajax Load More » Not functioning on some Chrome browsers

  • Resolved jvmedia

    (@jvmedia)


    Hi there –

    We’ve been trying to troubleshoot why this doesn’t seem to be working for our client. We can’t replicate the issue on our end on any computer in our office or browser that we’ve tried. The client is using:

    Chrom: Version 74.0.3729.131 (Official Build) (64-bit)
    macOS: Version 10.14.4 (18E226)
    macOS: Version 10.12.6

    What’s happening is that instead of getting the loading of more posts, it just doesn’t do anything. We are using Ajax Load More with your paid theme repeater plugin and we did update the Ajax Load More last week (sadly, the client just came to us yesterday about the issue and since we aren’t getting, we can’t say that it exactly coincide with the update, but that’s our haunch).

    Any ideas on something else we could check. We’ve ruled out plugin conflict simple because it’s otherwise working on browsers and devices we’ve checked. Hopefully you have some insight as to what might cause isolated incidents like this.

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author dcooney

    (@dcooney)

    Hi @jvmedia
    Im using that same client set up and it’s working for me in Chrome.

    Is there any JS errors in the console for the client? I assume you have them clear there browser cache?

    Hi @dcooney,

    We did make sure everyone cleared their cache. Errors are:
    ajax-load-more.min.js:19 Uncaught TypeError: Cannot read property ‘active’ of undefined
    at Object.e.almGetAjaxUrl (ajax-load-more.min.js:19)
    at Object.n.AjaxLoadMore.adminajax (ajax-load-more.min.js:12)
    at Object.n.AjaxLoadMore.ajax (ajax-load-more.min.js:12)
    at Object.n.AjaxLoadMore.loadPosts (ajax-load-more.min.js:12)
    at Object.n.AjaxLoadMore.init (ajax-load-more.min.js:12)
    at new t (ajax-load-more.min.js:12)
    at ajax-load-more.min.js:12
    at Array.forEach (<anonymous>)
    at ajax-load-more.min.js:12
    at Object.<anonymous> (ajax-load-more.min.js:12)

    One other thing we noticed is there might be a conflict or something else going on because it’s displaying posts that are not within the category selected. When we turn off both plugins, it shows the proper posts in the proper categories. We’re also getting the message:

    Ajax Load More: Theme Repeaters
    You have version 1.1 installed. Update to 1.1.1
    Compatibility with WordPress 5.1.1 Unknown
    Compatibility with WordPress 5.2 Unknown

    When we do update it, we’re able to replicate the error of posts not loading (and that category issue is still happening).

    We also tried switching the jQuery file to the latest version but that didn’t help.

    Plugin Author dcooney

    (@dcooney)

    Hey @jvmedia
    ALM does not user or require jQuery so that doesn’t matter.

    I think this is a caching error.

    I don’t know if this helps but if you’re using WP Engine turning off Object Caching on WP Engine’s side helped clear this error up. Also deleting Autooptimize cache as well helps to solve the problem.

    It’s not a caching issue. We even turned off Cloudflare caching. It was also happening on all browsers, not just Chrome. We couldn’t find a way to fix it so we turned it off and are using pagination again. We’ll try reactivating on a future release to see if that magically fixes whatever the issue is.

    Plugin Author dcooney

    (@dcooney)

    @jvmedia You said in your initial post you actually could not replicate the issue.

    Plugin Author dcooney

    (@dcooney)

    Closing for now. Respond here if you can get the error appear.

    thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not functioning on some Chrome browsers’ is closed to new replies.