Support » Fixing WordPress » Not Found, Not Acceptable, All Too Much!

  • I’m not as clever as the rest of you. I had hoped I was smart enough to begin using this and be good at it, but things are stumping me right and left. I’ll try to isolate it to one or two here:

    Things worked okay except that I wanted to allow people to comment without having to go through the whole password in the e-mail thing.

    I open ‘Options | Discussion’ and uncheck all the boxes for:

    Before a comment appears:
    An administrator must approve the comment (regardless of any matches below)
    Comment author must fill out name and e-mail
    Comment author must have a previously approved comment

    But when I click ‘Update Options’, I get:

    Not Found
    The requested URL /wp/wordpress/wp-admin/updated=true was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Except that when I return to that screen, the boxes are in fact, unchecked…

    And I went to ‘Options | General’ and configured:

    Membership: Anyone can register
    Users must be registered and logged in to comment

    to Anyone can register, and unchecked the box for Users must be logged in…

    Again, when I try to ‘Update Options’, the same Not Found error appears…

    And now when I try to write a page or write a post, when I click on ‘Create New Page’ or ‘Save’, I get:

    Not Acceptable
    An appropriate representation of the requested resource /wp/wordpress/wp-admin/post.php could not be found on this server.

    I don’t have any permalink structures set because I don’t quite understand this yet, and the only .htaccess file I can find on my website is the one I modified once according to a tutorial on “A List Apart” about preventing image hotlinking (and I never got that to work successfully near as I can tell not having any friends I can ask to test from their remote locations), and this .htaccess file is way up in the root directory and I don’t know how to delete it and re-write it to something more generic since I wrote right over the existing one without saving a copy, (duh!), so there you have it. I’m trying to make my mess as neat as possible for the consideration of someone there to help me out. I believe the main issues are as staed above, and somehow the .htaccess file probably figures into this equation, but I’m so in the dark, I really could use a tech-savvy hand here and there. Oh and BTW, I’m trying to get used to using Firefox and Thunderbird in an effort to move away from IE and OE, and I really don’t understand the configuring of many other aspects of any of the above-mentioned applications. I know, I know…

    (Can I get a cheap techno-dude to come onsite and point some of this stuff out to me, explain why I would want one configuration over another?)

Viewing 8 replies - 1 through 8 (of 8 total)
  • Okay, so no reply. Well, it magically started working again, so I got brave and tried to do something about my permalink structure. Now it’s a NEW problem:

    (knowing this should help:)I have WordPress in rootdirectory/wp/wordpress.

    I have a .htaccess file in my rootdirectory (the one mentioned above – which I once tried to re-write according to a tutorial by Thomas Scott on “A List Apart” about preventing image hot-linking. I never got that to work. But my site continued to work okay anyway, so I left it alone.) I don’t remember if there was a .htaccess file there before I tried that tutorial, and if there was, I don’t remember what it looked like.

    My problem now stems from my attempt to structure my permalinks. I guess I really don’t know what I’m doing, and I hope I didn’t do any damage to the servers at my webhost.

    When I entered the variables I wanted for my permalinks, (taken directly from the example shown on the ‘Options | Permalinks’ page), I clicked ‘Update Options’ and the changes took effect. In a colored bar at the top of the page, it said “You should update your .htaccess file now”, and I scrolled down and saw the message: (to the effect) If your .htaccess was writable, WordPress would automatically re-write it to make the changes…

    I thought it was writable.

    I went into WS_FTP, and looked at the permissions. I guess they were 644, I don’t remember now. I changed them to 666, and went back to the dashboard and attempted to update the permalink options again to see if the message about my .htaccess would change from being “If it were writable…” to something like “WordPress has updated your .htaccess file…” It hadn’t.

    So I copied the code for the new .htaccess page, and I opened TextPad, pasted (appended) it to the .htaccess file in my powell3d-www directory, then I uploaded it and made sure the permissions were set to 666. After initially seeing my blog appear, but having the links return 404’s, I guess I tried “rolling it back to the original state”. Or maybe I tried stabbing in the dark, I don’t remember now. But anyway, at some point finally, all I was getting were 500’s (Internal Server Errors).

    That’s all I get now when I go to

    Are all my posts in my blog now named with the permalink stucture: %monthnum%/%day%/%postname%(whatever), yet the application thinks they’re still the old name?

    And is the fact that the .htaccess file is two directories up, what initially caused the 404’s, and is my re-writing and chmod-ing what got it all screwed up, or what? What can I do now to get everything back the way it ought to be?

    I was on #wordpress last night because my previous post here hasn’t gotten a reply yet(??), but that’s a totally new thing to me, and I don’t understand how to get understandable answers there. (People talk funny)

    Thanks in advance,

    (I know I know. I don’t belong in this league – who picked that guy anyway? (Shades of high school gym class))

    Okay, so I finally read all the text of the 500 page. The last line is (to the effect) “check the server error log”.

    And so I was able to log in to my website’s control panel where I can view the error log. I found some pretty good clues:

    [Wed Apr 6 06:23:03 2005] [alert] [client] /home/powell3d/powell3d-www/.htaccess: Invalid command ‘[NC]’, perhaps mis-spelled or defined by a module not included in the server configuration

    Well, that ‘[NC]’ was there all the time before, from that tutorial, but I guess it was ignoring it until I started playing around with things. So I finally deleted the stuff that comprised the part I figured was the code from the tutorial, but left the top part, and the re-direct I have in place at the bottom. Then came this error:

    [Wed Apr 6 06:28:04 2005] [alert] [client] /home/powell3d/powell3d-www/.htaccess: URL to redirect to is missing

    Well, it wasn’t missing, it had a hard break in it.

    Alas! My website and my blog now come up, but now I get

    Not Found
    The requested URL /wp/wordpress/2005/04/01/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    whenever I click any link on my blog.

    So problem mostly solved.
    How do I get the links to be recognized?
    My .htaccess file now has only this in it:

    RewriteEngine On
    Options +FollowSymlinks
    RewriteBase /

    Do I need a separate .htaccess file in my wordpress directory?

    Thanks for playing along,


    Okay, that was the answer. I needed a .htaccess file in the directory where index.php is. That happens to be in my rootdirectory/wp/wordpress.

    So I put a dummy one in there, and set its permissions to 666, and went to ‘Options | Permalinks’ again, and set the variables in there again, and clicked ‘Update Options’, and sure enough, the colored bar at the top of the page said (to the effect) “Your changes were updated…”

    And there was no text at the bottom saying anything like “if it was writable…”

    So there you have it. A .htaccess file has to be in the directory where the index.php file is!

    Thanks everyone for watching me play with myself. Now would someone comment on any other thing they think they got from this that points to me being really stupid so I can learn from it. Like, why do I have my index.php all the way down in two directories away from my root directory anyway?

    >Like, why do I have my index.php all the way down in two directories away from my root directory anyway?

    I was just going to ask that?

    …you’re going to say it’s not on purpose and why didn’t someone tell you…?


    I wish I had friends who could check out how I configure things on my computer and challenge me as to why they are that way. I’d probably change 80% of my system configurations.

    I make decisions based on something that I think makes sense at the time, and then realize later there was an easier/smarter way to do it.

    Security issues cause me to think and re-think why something should be set up a certain way, but I’m totally clueless and probably vulnerable to any sort of hacking. Anyway…

    Mark (podz)


    Support Maven

    #wordpress – people don’t so much talk funny (I think) as you need to get used to following (or ignoring) several conversations that can be going on at once. It can take a bit of getting used to, but #wordpress is a wonderful resource.

    As for someone checking things out – if it’s in your machine, we can’t but if it’s on a site, then if you trust someone to let them have a look it may allay any fears you have. If you are unsure about who to trust, then post their name – or even the suggestion – here.

    And as for hacking, your weakest point is your password. So long as that is a good one (8-16 random characters including a mix on numbers / letters / symbols) then you will be doing all you can.

    Well, when I needed a “cheap techno dude” I found that youngsters are too difficult to understand. First, they hog the keyboard, having no patience with a hunt ‘n ‘pecker, and slap keys so the widows rattle. Meanwhile I’m wondering what they told the box to do. They seem to have an intrisic knowledge, at least they project that confidence, but they can seldom articulate what the underlying strata is.

    Then I found an old, semi-retired micro-maniac who cut his teeth in the 70’s on Zilog 8-bit steam operated byte chuggers. He volunteers time to adult starter uppers. Doesen’t bother him a bit to spend a few days tweaking this and that on a new installation then wipe the whole thing away and install again with some different twist. He never panics — just says “Whatever it is, it can be fixed.” That’s why they call them programmable.

    We shouldn’t fall into the trap of thinking that oh so cool youngsters are any better than the old BBC Micro hackers who lurk in these parts. It is just that part of their mystique is making sure that what they do is incomprehensible to everybody else. Lest people do not know they are gurus. Do WP folk talk funny? Well yes. Many of us prolly do. Kinda 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not Found, Not Acceptable, All Too Much!’ is closed to new replies.