WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Not found errors and unsecure content

[Resolved] Not found errors and unsecure content

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Sed Lex
    Member

    @sedlex

    Could you confirm me that your blog is at https://amigogeek.net
    I assumed that the problem come from the tabulation “More plugins” where all my plugin is displayed.

    Nevertheless I do not understand why the URL of the image is http://gs1.wac.v2cdn.net/extend/plugins/spam-captcha/screenshot-4.png?r=0.
    It should be http://s.wordpress.org/extend/plugins/spam-captcha/screenshot-4.png?r=0.

    Plugin Author Sed Lex
    Member

    @sedlex

    I propose to modify this tab to change http://s.wordpress.org/ into https://s.wordpress.org/ when the connection is secure

    cadusilva
    Member

    @cadusilva

    Yes, AmigoGeek is my blog. And actually, https://s.wordpress.org gives a warning because the cert is for the domain gp1.wac.edgecastcdn.net only.

    Plugin Author Sed Lex
    Member

    @sedlex

    … hum you are definitely right …
    But it is not on my side and I am not sure to be able to do something for that.

    The only thing that I may propose is to propose an option to block the downloading of the images from http://s.wordpress.org

    cadusilva
    Member

    @cadusilva

    I’ve changed the file otherplugins_xxxxxx.data located at /core/data/ and now the SSL is no more broken. But still, the plugin page shows like this http://d.pr/i/vQn4+ and I can’t edit the two entries listed in the picture.

    Plugin Author Sed Lex
    Member

    @sedlex

    hum … is it like that since you modified the file otherplugins_xxxxxx.data ? (with https://s.wordpress.org I suppose ?)

    cadusilva
    Member

    @cadusilva

    No, see in the first message. Since then I couldn’t edit anything anyway. Now I just kind of worked around the SSL problem, but the edit part is still broken.

    By the way, the SSL “fix” is:

    – Change every mention to http://s.wordpress.org -> https://gp1.wac.edgecastcdn.net. The downside is that the Other Plugins list is blank as if I’ve alread installed them.

    Plugin Author Sed Lex
    Member

    @sedlex

    You must have a JS and a CSS issue then. May I have an access to your admin panel to debug the JS and the CSS ?

    cadusilva
    Member

    @cadusilva

    Give me your email.

    Plugin Author Sed Lex
    Member

    @sedlex

    you have it in the header of the plugin file or you have the feedback tab -> I will resend you an email back

    cadusilva
    Member

    @cadusilva

    Sent.

    cadusilva
    Member

    @cadusilva

    The problem is now solved.

    Solution: the frontend theme had some function to remove script versions and anything after a “?”.

    Thank you Sed Lex for the support 🙂

    Plugin Author Sed Lex
    Member

    @sedlex

    You are welcome

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Not found errors and unsecure content’ is closed to new replies.