Support » Fixing WordPress » “Not Found” errors after upgrade to 2.7

  • Resolved Fauxlimey


    I just upgraded to 2.7, and my blog works fine as far as I can see. I can write and edit posts. The problem is that I can’t update my profile page, or enter my API key to activate a plugin, for example. I get the following error message when I try:

    Not Found
    The requested URL /stuff/wp-admin/(EmptyReference!) was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    The EmptyRefence! part leads me to believe that the problem is not in the wp-admin folder (which I have removed and replaced since discovering this problem) but rather in the instructions being generated by the Update buttons.

    Any ideas? (I’m not much of a code-head, so please be gentle!)

Viewing 7 replies - 1 through 7 (of 7 total)
  • did you deactivate your plugins before upgrading – sounds like one of them may be messing with you
    try deactivating them and see if you still have a problem
    if not, activate them one by one until you find the offender

    I deactivated them before the upgrade, as per the upgrade instructions, and I just checked. They remain inactive.

    After updating to WP 2.7, I am also getting 404 Not Found when I try to edit a post. When I click on the Update Post button, there is a long delay then the 404 Not Found.

    The problem seems to be in the Editor. When I first tried to edit the post, I got the Visual editor but it showed all the HTML and the HTML tab was disabled. I couldn’t get to the HTML editor until I clicked on the Visual tab, which switched the HTML to the Visual view–then the HTML tab was enabled and I could get to that editor. After making my update, I clicked on Update Post and got the 404 error. I tried this 3 times and got 404 Not Found each time.

    The fourth time, I tried inserting the update in the HTML that showed in the Visual editor. After I clicked Update Post, I got an Internal Server Error message combined with a 503 error.

    I tried installing Gears, enabling it, and editing. I was able to get to the HTML editor just fine. I managed to do two edits but the third edit still gave me a 404 Not Found after a long wait when I clicked on the Update Post button. Using Gears and Turbo did nothing to speed anything up either. I tried all the steps in the referenced link and the problem remains–the Update Post button is unstable.

    Hey! What about me? Just kidding, kinda. I can update posts with no problem. My blog works fine, aside from my update button problem, as far as I know.

    Found it! The problem was GoLive. I deleted and replaced the wp-admin folder using Fetch, and the problem is gone. I should have recognized the EmptyReference! as a GoLive term, and searched this forum for that in the first place.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“Not Found” errors after upgrade to 2.7’ is closed to new replies.