Support » Fixing WordPress » Not Found 404 error on one post. URGENT!!!

  • Hi

    I have a strange problem
    When I try to go to a certain post on my website, I get the Not Found 404 error.
    all other posts are OK.
    I tried deleting and reposting with the same post name but with no success.
    I tried also to save again in Permalink Settings but with no success.

    the permalink of this post is very important since lots of external inks are directed to this link:
    http://babygenderonline.com/determine-baby-gender/

    Please assist ASAP.
    thanks
    Malka

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi

    (@esmi)

    Forum Moderator

    Is the post visible in Admin -> Posts -> All Posts? What happens if you switch to the default permalink structure?

    thanks for your reply

    Yes it is visible. If I click on ‘view’ then I can see the post correctly.
    Only when reaching from outside I get the 404 error.

    I dont want to switch to default permalink since its very important that I keep the current permalinks.

    esmi

    (@esmi)

    Forum Moderator

    This is part of the troubleshooting process. Please try switching to the default permalink structure temporarily.

    OK I switched to default permalink.
    It doesnt seems to refresh. IE still remembers the old permalink.

    Now its working OK with the default permalinks.
    what do we learn from his?

    esmi

    (@esmi)

    Forum Moderator

    That there could be an issue with the way that your current server is dealing with rewritten urls. What custom permalink structure were you using previously?

    post name
    http://babygenderonline.com/%postname%/

    If its a server problem, why does it affect only this post?

    esmi

    (@esmi)

    Forum Moderator

    What happens if you use one of the numeric permalink structures?

    Its working OK as well.

    Michael

    (@alchymyth)

    Forum Moderator

    why does it affect only this post?

    it might have been a conflict with a category of the same slug (determine-baby-gender) which got settled with the re-writing of the permalinks.

    now I switched back to /%postname%/ and the problem returned.
    I dont know why just this post.

    esmi

    (@esmi)

    Forum Moderator

    As alchymyth said, there could be a clash between this post’s title and the title of an existing page, category or tag.

    alchymyth, YOU ARE THE MAN!
    esmi thanks for re-emphasizing alchymyth’s words again.

    It was a hidden duplicate page I didnt notice.

    THANK YOU!

    malka

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Not Found 404 error on one post. URGENT!!!’ is closed to new replies.