• Just upgraded to the latest version of the plugin 1.3.1.1, and now any email sent from the UpdraftPlus 2.16.19.24 backup plugin has lost all its formatting.

    There are no line breaks at all in any of the emails sent from Updraft so it is very difficult to read.

    The Updraft plugin has not changed and this was not happening before the upgrade to 1.3.1.1

    Test emails sent from the Customizer, look OK so not sure why this is now happening

Viewing 15 replies - 1 through 15 (of 25 total)
  • Any chance to see screenshots of how that email looks and how it should look?

    Thread Starter dbm44

    (@dbm44)

    Hi,

    Here are the screenshots of the first couple of lines of the email, just below the header which shows OK. The footer also shows OK, just the content which does not

    Old plugin which looks OK

    New plugin version which strips all line breaks from the content

    Hello, I have the same problem !!!

    My email text has no more line breaks !!

    I set into my email strings the “\n” characters that was working well and added a new line before the last update.

    Now all the text has no more line breaks and all the text in the email is stucked !!!

    Thanks for your help,
    Best

    • This reply was modified 4 years, 7 months ago by seb06.

    Hello, I have the same problem too

    no line breaks

    How can I fix it

    Thx

    @seb06 and @bsajie , are you also talking about UpdraftPlus ?

    I tried the free version and it’s working. Is the premium giving issues?

    Version: 1.16.17

    @bcrodua could you help me out in here?

    Thread Starter dbm44

    (@dbm44)

    @timersys

    Yes I am using the premium version of UpDraftPlus. This sends a much more detailed email after the backup compared to the free version

    Thread Starter dbm44

    (@dbm44)

    It is not just UpDraftPlus that is affected though.

    I have just noticed that emails on another site using the Simple Basic Contact Form plugin are also having their new lines stripped.

    Again, this was not happening before the 1.3.1 update

    I do not use at all UpdraftPlus !!

    For your information, I am reverting back to your previous version and all is working fine again, the line breaks are still here…

    Thanks for your help,
    Cheers

    @dbm44 are you using 1.3.1.1 ? the plugin s works for me with simple basic contact form

    @seb06 could you tell me which plugin i’t sfailing.. ?

    If I can’t test it I can’t fix it.

    On my local tests version 1.3.1.1 works fine .

    If you could provide premium version of updraftplus send it to info at timersys.com

    Thread Starter dbm44

    (@dbm44)

    @timersys

    Thanks for trying to fix this

    Yes I have the latest version of the plugin, 1.3.1.1 and it is stripping the line breaks with simple basic contact form on multiple web sites on 2 different hosts.

    I am also using the Mailgun plugin, but I have tested with and without this plugin and it makes no difference, the line breaks are removed.

    I have just removed 1.3.1.1 and reinstalled 1.3.1 and it works OK, the line breaks are there in both simple basic contact form and UpdraftPlus.

    So whatever is stripping the line breaks, was introduced with the 1.3.1.1 changes

    Hi @dbm44, try deactivating all plugins except email templates and contact form to see if the error still happens.
    I can’t reproduce locally.

    Thread Starter dbm44

    (@dbm44)

    Hi @timersys

    Thanks again. OK so I have had a couple of hours to test various issues.

    I have tested a couple of sites without any other plugins except for email templates and the contact form, and on their own it works OK.

    I found that as soon as a caching plugin is activated, then the line breaks are removed from the contact form using email templates.

    I have tried excluding the contact form page from the cache but this makes no difference, the line breaks are always removed.

    The WP Rocket plugin and WP Fastest Cache both remove the line breaks from the contact form with email templates as soon as they are active.

    This contact form issue only happens with 1.3.1.1. Version 1.3.1 with a caching plugin works OK.

    The caching plugin has no effect on UpdraftPlus emails, these simply do not format in version 1.3.1.1 with and without the caching plugin active.

    Can you now reproduce this issue with a caching plugin installed?

    Hi @dbm44,
    could you share access to your site so I can test in there?

    Thread Starter dbm44

    (@dbm44)

    Hi @timersys,

    No sorry, unfortunately I am not allowed to permit third party access to these servers.

    What changes were made between 1.3.1 and 1.3.1.1 that would cause the caching plugins even when not active on the page to strip the line breaks?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Not formatting UpDraft messages with latest version 1.3.1.1’ is closed to new replies.