WordPress.org

Forums

[resolved] Not finding CSS (11 posts)

  1. beff_face
    Member
    Posted 6 years ago #

    http://www.eurofusion.net/gazaguide

    My above theme does not appear to be pulling the style.css file! Although it appears to be recognising it.

    This is what Im using to pull it in:
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    the stylesheet can be found at
    http://www.eurofusion.net/gazaguide/wp-content/themes/guide/style.css
    and this is showing in the wordpress back end editor.

    interestingly, when I go to view what CSS style is associated with the homepage, it shows the following:
    http://www.eurofusion.net/gazaguide/Gaza%20Guide (this doesnt even exist!)

    Any help would be greatly appreciated!

  2. ClaytonJames
    Member
    Posted 6 years ago #

    From the source code:

    <link rel="stylesheet" href="Gaza Guide" type="text/css" media="screen" />

  3. beff_face
    Member
    Posted 6 years ago #

    where do I change that?
    As in my header file, I have it as the following:
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

  4. ClaytonJames
    Member
    Posted 6 years ago #

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    That actually looks okay to me. Anything weird in your Dashboard > Settings > General >

    WordPress address (URL)

    Blog address (URL)

    Do those look alright?

  5. beff_face
    Member
    Posted 6 years ago #

    http://www.eurofusion.net/gazaguide

    they both have the above?

  6. ClaytonJames
    Member
    Posted 6 years ago #

    I am afraid I am at a loss for ideas.

  7. beff_face
    Member
    Posted 6 years ago #

    ooh ok, thanks for trying!

  8. chaoskaizer
    Member
    Posted 6 years ago #

    Edit your theme's header.php.

    find

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    replace it with

    <link type="text/css" rel="stylesheet" href="<?php echo trailingslashit( get_bloginfo('template_url') ); ?>style.css" media="screen" />
  9. chaoskaizer
    Member
    Posted 6 years ago #

    BTW there is something wrong with your wordpress blog.. seem like all the links return 404 (not found). You might have different problem entirely

  10. beff_face
    Member
    Posted 6 years ago #

    oh Im aware the links are working... I havent set anywhere for them to go yet. Lemme try your code.

  11. beff_face
    Member
    Posted 6 years ago #

    it worked! thank you chaoskaizer.

Topic Closed

This topic has been closed to new replies.

About this Topic