Support » Plugin: WP RSS Aggregator » Not fetching feeds.

  • Resolved James Laws


    The WP Ninjas

    Installed, added to feeds, they never get fetched. Settings look fine and there is no errors being reported, just no feeds. Tried fetching manually several time but nothing it doesn’t work.

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multi-site: No


    Plugin Version: 4.1.3
    WordPress Version: 3.8.3

    Platform: Apple
    Browser Name: Chrome
    Browser Version: 34.0.1847.131
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_9_2) AppleWebKit/537.3
    6 (KHTML, like Gecko) Chrome/34.
    0.1847.131 Safari/537.36

    PHP Version: 5.3.2-1ubuntu4.19
    MySQL Version: 5.5.30-30.2-log
    Web Server Info: Apache

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Post Max Size: 100M
    PHP Time Limit: 3600

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 3 Status: Acceptable

    Show On Front: posts
    Page On Front: #0
    Page For Posts: #0

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /var/lib/php5
    Use Cookies: On
    Use Only Cookies: On

    WordPress Memory Limit: 40MB
    FSOCKOPEN: Your server supports fsockopen.


    WP RSS Aggregator: 4.1.3


    Akismet: 2.6.0


    Twenty Fourteen: 1.0

    ### End System Info ###

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Miguel Muscat


    Hi James,

    Do you see any feed items in the Feed Preview?

    Also, how are you performing the manual fetching? From the Debugging page, or from the All Feed Sources page (‘Fetch feeds” link, when hovering over a feed source in the feed source list) ?

    James Laws


    The WP Ninjas

    Feed preview shows the proper feeds.

    I’ve tried it both ways and neither seems to do anything at all.

    I am having the same problem as this.

    Feed preview fine, but no feed importing taking place

    Plugin Author Miguel Muscat



    Are you sure all your settings accommodate the feed items you wish to import?
    Mainly, you’d want to check the “Limit” option and the “Delete feed items older than” option in the create/edit feed source page.

    The first should not be zero, while the second should be set to an age that is at least older than the age of the first feed item in the preview.

    James Laws


    The WP Ninjas

    Plugin Author Jean Galea


    Hi James,

    I created a new site on WP Engine, added the WP RSS Aggregator plugin, added the feed from WP Mayor, and hit publish. Then I created a new page and inserted the shortcode [wp-rss-aggregator]. Everything worked fine. I left all default settings as they are.

    That’s the closest I can come to setting things up as you did. Have you done anything different from what I described? If you’d like us to take a look at your installation you can email credentials to your test site to


    Hi guys,
    I am having the same problem. I am using wordpress 3.9, feeds show up in preview but they never get fetched and the page displays “no feed items found”. Checked the limit and age settings, and they are good.


    I had this problem and had to do a couple things to fix it.

    1. Removed .htaccess basic authentication. My site was on a password protected staging server with basic auth, and that seemed to be causing issues.

    2. Install WP Crontrol plugin and cleared out stuck cron processes for RSS Aggregator.

    As soon as I did these steps my feeds started importing.

    Plugin Author Miguel Muscat



    Beat me to it! haha

    It seems that under certain circumstances that I have yet to identify, some cron jobs seem to get stuck. I am not sure if this is caused by our plugin, other conflicting plugins or WordPress itself, but we will look into it.

    Try either running or deleting the cron jobs. Cron jobs marked as recurring should reschedule themselves automatically, so you don’t have to worry about breaking the plugin.

    Here are the cron jobs to look for:

    Updates all feed sources.
    This should be marked to recur according to your update interval setting.

    Updates a single feed source. Should have the feed source’s ID as an argument.
    This should either spawn when the wprss_fetch_all_feeds_hook is run, or recurs according to the feed source’s own update interval.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Not fetching feeds.’ is closed to new replies.