WordPress.org

Forums

not displaying in WP 2.8 (14 posts)

  1. Grumbledook
    Member
    Posted 6 years ago #

    It has stopped working in 2.8, both before and after upgrading the plugin to 0.4.7-1

    It doesn't show up on the pages or in the preview are in the options for the plugin in the admin area

    I just get a blank area with a text box (no border) to type in (both firefox and chrome)

  2. steupz
    Member
    Posted 6 years ago #

    Might be your theme, try using it with another theme as a test

  3. User3298
    Member
    Posted 6 years ago #

    This is working fine for me unless I make a certain setting under Discussion Settings:

    Users must be registered and logged in to comment

    When this setting is checked, the wysiwyg editor does not display using the default Single.php template.

    Deselecting this setting returns the wysiwyg editor to the front end.

  4. mk_is_here
    Member
    Posted 6 years ago #

    User3298, thanks for your report. I'll test and see if there are anything I can do.

  5. Grumbledook
    Member
    Posted 6 years ago #

    Right, I upgraded my other blog which I also have this installed on.

    After upgrading to 2.8 I checked a thread and it was still working fine. I then remembered that the plugin wasn't the current version as well so I upgraded that, then it did the same thing as my other blog.

    So you lose the buttons at the top and the text area is just white with no border (fine on one but the other site has a white bg as well so you can't tell it is there unless you click and get a typing cursor)

    As mentioned in the first post it displays the same in the preview area on the admin MCEComments Options page, so I didn't think it was theme related.

    Now it has done the same thing on two different blogs using different themes it makes me think it is less likely to be the themes. If you want me to do any testing then I'll be happy to.

    I also tried turning on the logged in users as well and as reported above it appears that the plugin "turns off" and you get the normal text box as if the plugin wasn't activated.

  6. Grumbledook
    Member
    Posted 6 years ago #

    Ah ha!

    Had a brainwave and it is the skin that is the problem. If you change it to "default" or "wp_them" then it works ok. (though both look the same to me)

    If you leave it as "o27k" which was the default after upgrading the plugin then it doesn't work.

    Still doesn't work at all if you have users must be logged in turned on, though I don't use that.

    Hope this helps

  7. Grumbledook
    Member
    Posted 6 years ago #

    ok latest update seems to have fixed that o27k one

    now the wp_theme one has no border (though that might be the skin)

    had to switch to default (wp_theme used to look the same as the default)

    any plans to add the o27k silver skin as well to the drop down list before I stark hacking at stuff?

  8. bibledude
    Member
    Posted 6 years ago #

    I'm having this problem too, but this thread just lost me. I want to check out the 'o27k' fix, but where would I be looking for that? I think I'd be fine if someone could point me to the right place on this...

  9. User3298
    Member
    Posted 6 years ago #

    bibledude - it's in the latest update http://wordpress.org/extend/plugins/tinymcecomments/

  10. HappyApple
    Member
    Posted 6 years ago #

    TinyMCE stopped working for me since 2.7. I can't figure it out. I am currently using Water Drops Theme 1.5. But I've tried the default theme as well as others. same thing. Looking at the source of the comment page I saw that for some reason its not loading the JavaScript into the page that makes TinyMCE appear. However when I go to TinyMCE's setting it appears just fine and the JavaScript is there when I view the page's source. Any help would be greatly appreciated.

  11. john-john
    Member
    Posted 6 years ago #

    It stopped working for me too in WP 2.8 -- I tried the skin suggestion, but no dice.

    Are there any other WYSIWYG commenter plug-ins?

  12. amcleod
    Member
    Posted 6 years ago #

    It doesn't work in 2.8 if Users must be registered and logged in to comment is selected. Has anyone figured out a work around? This is a an awesome plugin.

    Thanks!

  13. User3298
    Member
    Posted 6 years ago #

    tinyMCEComments.php basically figures out if a comment form should be there, then adds the tinyMCEComment code

    so I looked at comments.php to compare how the two files determine whether a comment form should be displayed.

    The problem was a faulty logic test in these two functions:
    tinyMCEComments.php: mcecomment_init()
    tinyMCEComments.php: mcecomment_loadCoreJS()

    Replace this faulty code
    if ('open' == $post->comment_status && ( !get_option('comment_registration') || $user_ID )) {

    with this working code
    if (comments_open() && ( !get_option('comment_registration') || is_user_logged_in() )) {

  14. HappyApple
    Member
    Posted 6 years ago #

    Thank you so much User3298!!! I just tried it out and it works perfectly! :D I love this plugin and it is sooo great to have it back.

    Again, thank you!

    One very,
    HappyApple.

Topic Closed

This topic has been closed to new replies.

About this Topic