Support » Plugin: Contextual Related Posts » Not Displaying Anything

  • Resolved kapson

    (@kapson)


    Dear Team,

    I have tried this plugin with default “Twenty Nineteen” theme as well as the commercial theme “https://squaretypetheme.com/” I want to use for my website: https://www.quotespedia.org

    Don’t know why but it’s not working on both of the template.

    It’s not displaying anything, even if I set it to “Show when no posts are found: Display custom text” It doesn’t show anything.

    Note: My posts doesn’t have any images but all my posts has “Featured Image”

    kindly help.

    Thank you
    Best Regards
    Kapil

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Ajay

    (@ajay)

    Will you be able to debug using Query Monitor plugin and then going to the post. This should then have a toolbar at the top where you can see the queries generated by the plugin

    Are you using the default settings of the plugin?

    Dear Ajay,

    Please find attached image what I received after debugging with Query Monitor.

    [img]https://i.ibb.co/B3dpLwn/crp-error.jpg[/img]

    https://ibb.co/nmZGrRP

    I have changed some Contextual Related Posts settings to check if it works.

    Thank you for your support

    Best Regards
    Kapil

    • This reply was modified 2 months, 2 weeks ago by  kapson.
    Plugin Author Ajay

    (@ajay)

    @kapson

    I suspected this might be the case – are you on a host that does not allow this plugin or does not allow fulltext indices? Worth writing to them and checking it as without the fulltext index you won’t be able to use the plugin.

    Dear Ajay,

    I am on my dedicated server, so no issue with restriction/host.

    If you can guide me little a bit, I will be able to enable this.

    I am not much technical, but I can do if you help me with this.

    I use Plesk Onyx and MySql 5.5.60

    It’s strange that on the same server with the same configuration my other websites are running perfectly “Contextual Related Posts”.

    This website is my fresh installation.

    Thank you for your great support.

    Best Regards
    Kapil

    Plugin Author Ajay

    (@ajay)

    That’s good. Can you try to generate the index using the button under Tools page – link in the settings page. You can also use the code generated there and run it in phpMyAdmin.

    One thing that springs to mind is that you have a relatively older version of mySQL and you’re using innoDB for the wp_posts table. I thin this was enabled in v5.6 onwards. One option here is to upgrade mySQL to at least 5.6 or another option is to convert the wp_posts table to myISAM

    Dear Ajay,

    I converted my post table from InnoDB to myISAM

    This page helped me: https://crunchify.com/how-to-convert-wordpress-database-from-innodb-to-myisam/

    But still it seems something is wrong.

    Please find attached image for reference.

    https://ibb.co/pwzWqz2

    You can check it live here: https://www.quotespedia.org/authors/g/gordon-b-hinckley/without-hard-work-nothing-grows-but-weeds-gordon-b-hinckley/

    Kindly help.

    Thank you for your great support
    Best Regards
    Kapil

    Plugin Author Ajay

    (@ajay)

    If you navigate to the Tools page, you should have the code ALTER TABLE code as in this screenshot – https://ps.w.org/contextual-related-posts/assets/screenshot-10.png?rev=2061733

    You’ll need to run that to create the indices

    Dear Ajay,

    This solved the database error.

    I am happy now 🙂

    Thank you for your great support.

    Best Regards
    Kapil

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.