Support » Plugin: BackUpWordPress » Not deleting old backups

  • Resolved zoondich

    (@zoondich)


    You have a great plugin. Bravo!

    I have set the plugin to make an automatic backup once a week, wich is working great.

    I also set the plugin to store only one backup. However, when I go to the setting panel to check if the last backup occured, I always see 2 backups (the new backup + the old backup).

    I also see that the old backup is taking a certain amount of space on my server.

    To be able to delete the old backup, I have to refresh my browser manually when I’m setting panel each time.

    Is it normal?

    • This topic was modified 3 months ago by  zoondich.
    • This topic was modified 3 months ago by  zoondich.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author katmoody

    (@katmoody)

    I have noticed that this happens for a few users and I’m not sure why. Do you have any kind of caching enabled on your server? Or anything disabling the ajax by chance? The final reload that clears the old backup away relies on the ajax I think.

    Let me know?

    Kat

    zoondich

    (@zoondich)

    I installed the plugin on 4 differents sites. Same thing happens on each site

    Plugin Author katmoody

    (@katmoody)

    And are they all using any caching plugin, same or different servers and any server-side caching, etc?

    Thanks!
    Kat

    zoondich

    (@zoondich)

    I don’t have any caching plugin on those site and server is the same for all.

    However, I am scheduling Cron Job in cPanel instead of the WordPress WP_CRON

    I’m using this script in wp-config.php to desactivate WordPress WP_CRON
    define (‘DISABLE_WP_CRON’, true);

    Can this have an impact on caching?

    Plugin Author katmoody

    (@katmoody)

    Yes that would have an impact, not on caching, but on the way the backups work – our scheduled backups use WP_Cron to signal when to run backups close to the time set in the schedule. So disabling WP_Cron completely means that those won’t run.

    Here’s one of our articles on working with WP_Cron – https://bwp.hmn.md/knowledge-base/wp-cron-help/

    Can I ask why you’re doing the Cron job in the cPanel instead? There might be other options available?

    Thanks,
    Kat

    • This reply was modified 2 months, 3 weeks ago by  katmoody.

    Because some of those site have low traffic. I thouhgt Cron job was the way to solve the problem

    Plugin Author katmoody

    (@katmoody)

    You don’t have to disable the wp_cron in order to set up that cron job, though. I think if you leave the cron job in place and re-enable the wp-cron you’ll see that the backups work again. Let me know?

    Thanks,
    Kat

    Thanks for your answer.

    I also tried with wp_cron enabled but still have the same problem

    jc 🙂

    Plugin Author katmoody

    (@katmoody)

    Were you able to find a way to work around this? I was just going back through older support requests to see if there were any that needed followup and saw this one.

    Kat

    Thanks for your reply

    I installed another plugin

    Plugin Author katmoody

    (@katmoody)

    I’m sorry ours didn’t work for your needs – thanks for updating me!
    Kat

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.