Support » Plugin: BackWPup - WordPress Backup Plugin » Not deleting backups from older versions…

  • Resolved kuphd1

    (@kuphd1)


    I have to say, I’m really not liking the fact that I now have to monitor 22 different websites to manually delete older backups from scheduled backups. What’s the point of this file tracking and it’s ugly file names anyway? It worked fine without it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi @kuphd1. It should be tracking and deleting anything created after 3.4.0. You have the choice of either keeping the old archives, or deleting them as you see fit.

    Hi Brandon,

    All I’m saying is it would’ve been nice not to have to go back and manually delete the previous version’s backups so as to not fill up all of our storage space on our servers and/or external backup sites. In my case, I’m going to have to manually clear all of these old backups on both my servers and my Dropbox account since I’ve got scheduled backups set. This is a huge pain that shouldn’t have been necessary. Right now, I have one site that has almost 6GB of old backups that are just sitting there taking up space.

    Oh… and it’s not deleting the new version’s backups from the server either. It’s looking like I may need to downgrade your plugin ’til you can get this fixed.

    Hi @kuphd1, that was a bug we discovered some users have been experiencing, which is fixed in the next version.

    Hopefully that’ll be out soon since I just had a site’s backup fail because it’s storage quota had been exceeding by the backups.

    It will be out next week. If you like, you can contact us and request the beta of the next release, which contains the fix.

    Hi.

    Same here as I use Dropbox as a backup storage for many websites, it goes freak on not deleteing old backups.

    I’d like to test the beta 😉

    Hi @draky, please contact support [at] backwpup.com and we’ll be happy to share the beta with you.

    Benny

    (@bennygiesbers)

    Deletion of old backups worked fine up until a week ago or so. Now my backups to Dropbox are failing regularly because everything is piling up fast. I hope that new version that fixes this is released very soon.

    Same problem here. New backups won´t be replaced. I have to delete them manually. When will new version come?

    Best regards,

    Chekki

    Hi @chekki, the new release will be next week. But as above, if you’d like the beta, feel free to contact us.

    can’t even downgrade to a previous version that used to work. backups totally fail. i used to love this plugin. now it’s making my life miserable. what the heck happened?

    Hi @kuphd1, I’ve tried to give alternative solutions in this thread. If you’re comfortable enough with code, it’s a one-line fix.

    In inc/class-job.php, on line 2514 or so, you’ll see this:

    $regex = "/^" . str_replace( $datevars, $dateregex, preg_quote( self::sanitize_file_name( $this->job['archivename'] ) ) ) . "$/i";

    It must be changed to:

    $regex = "/^" . str_replace( $datevars, $dateregex, preg_quote( self::sanitize_file_name( BackWPup_Option::normalize_archive_name( $this->job['archivename'], $this->job['jobid'] ) ) ) ) . "$/i";

    Or else you may ask us for the beta, which has fixed this issue as well.

    Sorry for the intrusion guys but I just discovered my old scheduled backups are not deleted and I just notice the extra mysterious warning in settings:

    Warning: Files belonging to this job are now tracked. Old backup archives which are untracked will not be automatically deleted.

    I’m on latest version 3.4, I read the above messages in this thread and still don’t understand what’s all about…

    Is this a bug, do I need to manually delete all old archives that were not automatically deleted or will this be corrected in upcoming version that will cleanup this stuff from there… Sorry I don’t get it.

    I read here that this “will be corrected” in next version. But what exactly will be corrected? The fact that old archives remain stored or also that old archives will be deleted?

    • This reply was modified 1 year, 11 months ago by  John.

    Hi @dsl225, all backups made prior to 3.4.0 must be manually deleted. If your backups after 3.4.0 are not being deleted, that is a bug and will be fixed in the next release. I hope that clarifies things.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Not deleting backups from older versions…’ is closed to new replies.