Support » Plugin: Duplicator - WordPress Migration Plugin » Not Creating Package or Installer

  • Resolved Shawn Q

    (@siddhachakra)


    I have the newest version of WP and Duplicator, I’ll perform the pre-scan and it’ll tell me that the package size is 235mb to download. When I click to create package set the progress bar will begin to load and then the page will automatically refresh and there won’t be anything there. Everything passes on the server compatibility list.

    I’ve deleted and re-installed a few times and even tried an older version and its still not creating a package for me. I’ve set the options processing time and memory to the max but still not working. Page just keeps refreshing and says “No packages found.”

    Any help on fixing this would be great, thanks

    http://wordpress.org/extend/plugins/duplicator/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Q,

    Its most likely a timeout issue with your hosting provider…

    Here is a helpful section on the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: “3. Troubleshoot”
    -> See Area/Question: “Timeout Issues”

    Hope that helps!

    Hi there,

    I had the same problem as Shawn Q. I followed the proposed link/solution by lifeinthegrid. Expecially the paragraph:
    – Try to exclude large files such as movies, large images or other backup files (like .zips or .tar files) from the options dialog.
    And the backup finished ok!

    ~Unfortunately i could not do a restore because my site was a Multisite. So, by the way, i believe it would be great if this plugin could work with multisite installations.

    In general, the plugin worked quickly and fine!

    Thank you very much lifeinthegrid!!!

    Plugin Author Cory Lamle

    (@corylamleorg)

    No Problem… MU is not currently supported, however we plan to have it integrated in the future…

    Hi there,

    I have the same issue. I raised the memory_limit to 2000M, I set the max_execution_time to 0, but still the same problem. here is what is on the diagnostic page of duplicator(sorry for this in German, but you can still compare them with an english one):

    Allgemein
    Duplicator-Version 0.4.4
    Betriebs-System Linux
    Webserver Apache/2.2.22
    Root Pfad xxxxxxxxxxxxxxxxxxx
    WordPress
    Version 3.5.1
    Sprache de-DE
    Zeichensatz UTF-8
    Speicher-Limit 2000M
    Maximales Speicher-Limit 256M

    PHP
    Version 5.3.19
    SAPI cgi-fcgi
    Benutzer xxxxxxxxxxxxxxxxxxx
    Safe Mode Off
    Speicher-Limit 256M
    Verwendeter Arbeitsspeicher 45,25 MB
    Maximale Ausf├╝hrungs-Zeit 0

    MySQL
    Version 5.5.28
    Zeichensatz utf8
    auf Timeout warten 3600
    maximal erlaubte Archive 16777216

    Server-Festplatte
    Free space 77.44% — 761.9GB from 983.82GB

    This is how the log looks like:

    ********************************************************************************
    PACKAGE-LOG: 10:41:24
    NOTICE: Do not post to public sites or forums
    ********************************************************************************
    duplicator: 0.4.4
    wordpress: 3.5.1
    php: 5.3.19
    php sapi: cgi-fcgi
    server: Apache/2.2.22
    browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0
    package name: 20130522_ringelpartner_neu_test
    php_max_time: set from=0 to=5000
    php_max_memory: set from=2000M to=5000M
    mysql wait_timeout:5000
    ********************************************************************************
    SQL SCRIPT
    ********************************************************************************
    xxxxxxxxxxxxxx

    SQL CREATED: /xxxxxxxxx/wp-snapshots/519ca0d4d96776066_20130522_ringelpartner_neu_test_database.sql
    SQL TOTAL RUNTIME: 8.7928 sec.
    ********************************************************************************
    ZIP ARCHIVE:
    ********************************************************************************
    ARCHIVE FOLDER: /xxxxxxxx/121213_RPLY_New
    ARCHIVE FILE: /xxxxxxxx/wp-snapshots/519ca0d4d96776066_20130522_ringelpartner_neu_test_package.zip
    FILTER EXTENSIONS: ”
    FILTER DIRECTORIES: ‘/xxxxxxxxx/wp-admin;/xxxxxxxxx/wp-content/uploads’
    —————————————-
    ZIPARCHIVE OPENED
    DATABASE.SQL ADDED TO ZIP: /xxxxxxxxxx/wp-snapshots/519ca0d4d96776066_20130522_ringelpartner_neu_test_database.sql
    ARCHIVE INFO: ZipArchive Object
    (
    [status] => 0
    [statusSys] => 0
    [numFiles] => 2391
    [filename] => /xxxxxxxxxx/wp-snapshots/519ca0d4d96776066_20130522_ringelpartner_neu_test_package.zip
    [comment] =>
    )

    STATS: Directories= 296 | Files = 2094 | Links = 0 | hidden files may not be counted on some servers

    Please do you have a solution?

    Manuel

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey m_anghel,

    It looks like your running into a possible timeout issue on your web server. This usually happens when the server your on terminates the PHP process before it can complete. Here is a helpful section on the FAQs page that might provide you some direction:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: “3. Troubleshoot”
    -> See Area/Question: “Timeout Issues”
    -> Also be sure to read the entire User Guide and FAQ page as it may have other answers that can point you in the right direction.
    -> If you discover a tweak/fix not on the FAQ please let me know what it was and it will get integrated into the plugin or on this FAQ.

    On a side note the WordPress moderators don’t like large log files posted to the forums… Next time I would just paste where the log file stopped reporting (maybe that last 5-10 lines)…

    Hope that helps!

    Hi,

    as I already pointed out, I have looked on the forum, read the troubleshoot pages and tried the solutions there. It seams to have something to do with the UpDraft plugin. Even when I made an exception on the settings to exclude /uploads and /updraft folders it still didnt worked. Desabeling the UpDraft plugin didnt help. After I removed the plugin and the folder everything worked fine, even with my 250Mb uploads folder. Thanks anyway, its really a great plugin, keep the good work ­čÖé

    manuel

    Plugin Author Cory Lamle

    (@corylamleorg)

    Yeah it may just be too much data or your host is killing your PHP process before the plugin can finish archiving the files and performing its routines. Some hosts will allow the PHP process to run much longer but you have to do some tweaks to your server setup. Some hosts just don’t care and kill the process no matter what…

    Thanks for the feedback!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Not Creating Package or Installer’ is closed to new replies.