Support » Plugin: Redis Object Cache » Not connected after connected

  • Resolved mike9712

    (@mike9712)


    Hello,

    When i make an new database in directadmin and i upload and activate the Redis opject cache plugin then i have for about a 5 minutes connection.
    After 5 minutes there is no connection annymore even after deactivating en activating caching, what could be the problem ?

    With kind regards

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    What error are you seeing under “Settings -> Redis -> Diagnostics”

    i get

    Status: Disabled
    Client:
    Drop-in: Invalid
    Redis Extension: 4.2.0
    Predis Client: 1.1.1
    PHP Version: 7.3.17
    Redis Version: Unknown
    Multisite: Yes
    WP_REDIS_HOST: “127.0.0.1”
    WP_REDIS_PORT: “7021”
    WP_REDIS_DATABASE: “0”
    WP_CACHE_KEY_SALT: “unlimited”
    WP_REDIS_PASSWORD: “***************”
    Dropins:
    – advanced-cache.php v by
    – sunrise.php v by
    Plugins:
    etc
    etc

    Before this, when there was connection i get

    Status: Connected
    Client: PhpRedis(v4.2.0)
    Drop-in: Valid
    Ping: +PONG
    Redis Extension: 4.2.0
    Predis Client: 1.1.1
    PHP Version: 7.3.17
    Redis Version: Unknown
    Multisite: Yes
    WP_REDIS_HOST: “127.0.0.1”
    WP_REDIS_PORT: “7021”
    WP_REDIS_DATABASE: “0”
    WP_CACHE_KEY_SALT: “unlimited”
    WP_REDIS_PASSWORD: “***************”
    Dropins:
    – advanced-cache.php v by
    – sunrise.php v by
    Plugins:
    etc
    etc

    Plugin Author Till Krüss

    (@tillkruess)

    Your object-cache.php dropin is invalid.

    Aha

    I see on the wp-content dir no object-cache.php

    Can i copy the object-cache.php from the redis zip file to : wp-content ?

    In anticipation of your answer, I copied it to the wp content

    stil not connected

    but now i get

    Status: Not Connected
    Client: PhpRedis (v4.2.0)
    Drop-in: Valid
    Ping: +PONG
    Redis Extension: 4.2.0
    Predis Client: 1.1.1
    PHP Version: 7.3.17
    Redis Version: 3.2.12
    Multisite: Yes
    Global Prefix: “”
    Blog Prefix: 1
    WP_REDIS_HOST: “127.0.0.1”
    WP_REDIS_PORT: “7021”
    WP_REDIS_DATABASE: “0”
    WP_CACHE_KEY_SALT: “unlimited”
    WP_REDIS_PASSWORD: “***************”
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “blog_meta”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”,
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “blog_meta”
    ]
    Unflushable Groups: []
    Dropins:
    – advanced-cache.php v by
    – Redis Object Cache Drop-In v1.5.7 by Till Krüss
    – sunrise.php v by
    Plugins:

    Plugin Author Till Krüss

    (@tillkruess)

    Now that’s strange, the ping worked, but it’s showing “not connected”.

    Are you seeing any errors in your log files?

    yes i see an error :

    2020-05-11 20:40:12.918836 [NOTICE] [2653796] [141.101.76.47:17666#APVH_www.xman.be] [STDERR] PHP Warning: Use of undefined constant …redis… – assumed ‘…redis…’ (this will throw an Error in a future version of PHP) in /****/****/****/******.**/public_html/wp-config.php on line 2

    at line 2 was : define(‘WP_REDIS_HOST’, ‘redis’);
    so i deleted that

    But stil no connection and i get these error :
    2020-05-11 20:53:23.952479 [NOTICE] [2653796] [162.158.234.147:26556#APVH_www.*****.**] [STDERR] RedisException: OOM command not allowed when used memory > ‘maxmemory’. in /****/****/****/(******.**/public_html/wp-content/object-cache.php:1133
    Stack trace:

    Plugin Author Till Krüss

    (@tillkruess)

    RedisException: OOM command not allowed when used memory > ‘maxmemory’

    Your Redis server is out of memory.

    Aha

    Thanks for the fast help and info

    I wil go with this information to my hosting

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.