Support » Plugin: Protect WP Admin » NOT compatible with WP 5.6

  • Junk, do not use. Updated to WordPress 5.6 and I am now locked out of ALL my websites. Avoid at all costs.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sysadmin

    (@palanthir)

    I do not maintain this plugin, I did not develop it and I am not the creator. Anyway I am sysadmin. The best idea in this situation is to login via ssh, or ftp to each server which hosts website , go to the location in public_html -> wp_content -> plugins , find the name of this plugin (it will be a directory called probably protect wp admin or similar) , do not remove it, but instead rename it (change the name of this plugin directory). I hope I explained it well. Then try to login using your login slug or wp-login.php and you should be able to login to your wordpress. I hoper I explained it enough clear.

    Plugin Author india-web-developer

    (@india-web-developer)

    We are sorry to hear that you are facing issue due to our plugin. I want to let you know that in wordprsss 5.6 version WordPress has done major changes to flush the custom rewrite and that’s why after update WordPress to 5.6 htaccess file is going to reset with default rewrite rules code. Due to these changes mostly all rewrite rules related plugin impacted.

    Please replace existing code of your htaccess file

    
    #This Apache config file was created by Duplicator Installer on 2020-09-22 13:50:01.
    #The original can be found in archived file with the name htaccess.orig
    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    


    With this one

    
    #This Apache config file was created by Duplicator Installer on 2020-09-22 13:50:01.
    #The original can be found in archived file with the name htaccess.orig
    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteRule ^myadmin/?$ /wp-login.php [QSA,L]
    RewriteRule ^myadmin/register/?$ /wp-login.php?action=register [QSA,L]
    RewriteRule ^myadmin/lostpassword/?$ /wp-login.php?action=lostpassword [QSA,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    

    NOTE: Don’t forget to update the value of new admin slug i.e myadmin with your own new admin slug that had added during setup new admin url.

    For any query you can contact us at info@wp-experts.in

    Many Thanks
    Raghunath

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘NOT compatible with WP 5.6’ is closed to new replies.