Support » Plugin: Lightweight Widget Area Plugin - Content Aware Sidebars » not compatible with wordpress 5.5 and higher

  • Resolved Deepak

    (@golinuxcloud)


    Hi,

    Recently I updated my wordpress to 5.6 and the settings option for this plugin was not working anymore.

    I have attached a screenshot of the faulty behaviour. I was not getting any option to add a condition.
    https://imgur.com/a/PQ55Obs

    Then I downgraded my wordpress to 5.3 and again that option was working properly.
    PS: I am disabling jquery using the following function in my functions.php, I hope this has nothing to do with this issue

    add_filter( 'wp_enqueue_scripts', 'change_default_jquery', PHP_INT_MAX );
    
    function change_default_jquery( ){
    	
    	if ( ! is_admin() ) {
        	wp_dequeue_script( 'jquery');
        	wp_deregister_script( 'jquery');   
    
    	}
    }
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Joachim Jensen

    (@intoxstudio)

    Thank you for reporting this.

    CAS is fully compatible with WP5.6 (and even bleeding edge versions of 5.7), but WordPress has been updating jQuery which can make outdated plugins cause JavaScript errors (as seen in your screenshot)

    Your snippet should have no effect on admin pages.

    I would recommend either disabling other plugins to find the conflict, or install
    https://wordpress.org/plugins/enable-jquery-migrate-helper/

    I hope this helps!

    Thread Starter Deepak

    (@golinuxcloud)

    Thank you for looking into this.

    I installed the helper plugin and that seemed to solve the issue. I was also getting similar error for other plugins but now they also are working.

    But just wondering if this is this a permanent solution or a temporary one?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘not compatible with wordpress 5.5 and higher’ is closed to new replies.