Support » Plugin: Smart Slideshow Widget (by obikui) » Not Compatible with WordPress 3.5?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Yes – it seems to cause problems with widgets, also with page editing.
    Causes a javascript error / conflict

    I found the same – when deactivating it, all problems went away.

    I also like this plugin, so hope an update will be on its way.
    Toby

    drew

    (@drewdrewchristophercom)

    Thanks to joshguss there is a fix that might work for some:
    http://wordpress.org/support/topic/smart-slideshow-widget-broken?replies=5

    And here is an alternative plug-in that works just as well: http://wordpress.org/extend/plugins/vslider/

    Issue is that smart-slideshow-widget.php calls for an outdated jQuery-ui script, which conflicts with changes made in WP 3.5. The plug-in should instead use the jQuery scripts that are included with WordPress.

    So replace

    (around line: 413)
    wp_enqueue_script('jQuery-UI-Effects', WP_PLUGIN_URL . '/smart-slideshow-widget/js/jquery-ui.min.js');

    with

    wp_enqueue_script('jquery-effects-core');

    At least with the other plug-ins I’m running with the Smart Slideshow Widget, the above edit fixed the Widget Page, Media Library, and Add Media issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Not Compatible with WordPress 3.5?’ is closed to new replies.