Viewing 4 replies - 1 through 4 (of 4 total)
  • MM Aurangajeb

    (@aurangajeb)

    Hello @alexliii

    Not compatible with wordfence

    Dokan doesn’t have any compatibility with the WordFence 2FA feature. Dokan uses the WooCommerce Account page to populate the Vendor and Customer registration form. However, it won’t work out if it doesn’t have any native integration or compatibility with the WF 2FA.

    Alternatively, you can look at this native solution to enable reCAPTCHA V3 with the Dokan Lite. And this additional reCAPTCHA plugin for the V2 checkbox.

    I hope this will help.

    Thread Starter alexliii

    (@alexliii)

    Hello,

    Thanks for reply.

    Just did a test with Dokan, and I noted google icon is showing on every page, is that expected?

    Anyway to hide that icon on other page exept login pages?

    Thanks

    Plugin Support Tanjir Al Mamun

    (@tanjiralmamun)

    Hi @alexliii,

    Wordfence 2FA feature setting is only available at the backend dashboard screen of WordPress. That’s why when a user register as a customer/subscriber, they do not find the way to setup the 2FA, as WooCommerce prevent customer/subscriber user role to redirect to the WordPress Dashboard. So, they cannot setup 2FA and due to required setting of Wordfence, they failed to login.

    In that case, either you can change the 2FA setting to optional, or you can disable the feature for those userrole.

    On the other hand, you can follow the @aurangajeb suggestion. But I could not get your recent problem that the google icon is showing on every page.

    However, from you first screenshot error message it looks like you have enabled the Dokan Email Verification feature.

    The Email Verification is a premium feature of the Dokan plugin, and as per the WordPress.org rules, commercial products are not supported here.

    If you are a premium user of the Dokan plugin, you can contact us through the proper channel for futher information.

    Thanks!

    Plugin Support Tanjir Al Mamun

    (@tanjiralmamun)

    Hi @alexliii,

    Due to inactivity, I am going to mark this topic as resolved. If you have any further queries, feel free to open a new topic.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.