Support » Plugin: Cookie Notice for GDPR & CCPA » Not compatible with the ‘Merge + Minify + Refresh’ plugin (js error)

  • SpabRice

    (@spabrice)


    Hello,

    I really like this plugin but it creates a javascript error in combination with the ‘Merge + Minify + Refresh’ plugin.

    I get the follwing error message in the console:
    $.fn.getCookieNotice is not a function

    How can I make them compatible?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author dFactory

    (@dfactory)

    Unfortunatelly we don’t know this plugin.
    But used a popular Autoptimize plugin successfully with CN and many other javascript related plugins. Can you try that?
    Or, if this plugin prvodies some minification options, try switching them in order to find a working combo.

    I use both the “Merge + Minify + Refresh” and the “Cookie Notice” plugins on a website, and I don’t have this error in the console.

    @spabrice, what kind of Minify settings do you have in place?

    I have JS minification disabled (can’t remember why I had to set it like that). HTTP/2 ticked, as well as the Gzip setting.

    Perhaps try that and see if the error goes away? Hope it helps.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not compatible with the ‘Merge + Minify + Refresh’ plugin (js error)’ is closed to new replies.