Support » Plugin: LH Multisite Ads » not compatible with php 7.2

  • PHP message: PHP Warning: in_array() expects parameter 2 to be array,
    2018/08/21 11:37:21 [error] 16422#16422: *105800 FastCGI sent in stderr: “PHP message: PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/epfb/wp-includes/post-template.php on line 284” while reading upstream, client: 162.158.106.131, server: epfbalancestatus.in, request: “GET / HTTP/1.1”, upstream: “fastcgi://unix:/run/php/php7.2-fpm.sock:”, host: “www.epfbalancestatus.in”
    2018/08/21 11:37:38 [error] 16422#16422: *105818 FastCGI sent in stderr: “PHP message: PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/html/raju/wp-content/plugins/lh-multisite-ads/lh-multisite-ads.php on line 413

    PHP message: PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/html/raju/wp-content/plugins/lh-multisite-ads/lh-multisite-ads.php on line 413

    • This topic was modified 1 year, 1 month ago by  thogarrai.
Viewing 1 replies (of 1 total)
  • Plugin Author shawfactor

    (@shawfactor)

    thogarrai,
    these are just a php warning (actually nothing to do with php 7.2), and does not stop the plugin working:

    http://php.net/manual/en/function.error-reporting.php

    Note the first set of warnings so not relate to my plugin at all, something else is causing them. Noting though itt would be unusual to have errors switched on on a production site as you will find unless every plugin you use it 100% perfect in all circumstances errors are generated.

    I´ll add a “fix” that should prevent this warning though in the next version of the plugin I am releasing shortly

    Pete

Viewing 1 replies (of 1 total)
  • The topic ‘not compatible with php 7.2’ is closed to new replies.