Support » Plugin: Dynamic Widget Content » Not Compatible With PHP 7?

  • Resolved sesecrets

    (@sesecrets)


    As more and more hosts are moving to PHP 7 due to speed and security issues, I’m going through client sites to check for compatibility and it seems your plugin is not compatible with PHP 7.

    The specific error messages I get are below. Will you be upgrading your widget to make it compatible any time soon? Neither of the issues are large and could be corrected within a couple minutes of coding.

    FILE: /home/atdcon5/public_html/wp-content/plugins/dynamic-widget-content/vendor/vafpress/includes/markdown/parser.php
    ———————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————-
    113 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ———————————————————————————————————————-

    FILE: /home/atdcon5/public_html/wp-content/plugins/dynamic-widget-content/vendor/vafpress/includes/wpalchemy/MetaBox.php
    ————————————————————————————————————————
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    ————————————————————————————————————————
    453 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    545 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ————————————————————————————————————————

    Thanks,

    John

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Brecht

    (@brechtvds)

    Hi John,

    Seems to be part of the library we use for the settings page. I don’t think it will cause any actual problems but I’ll release an update with this fix next week.

    Thanks for letting me know,
    Brecht

    Plugin Author Brecht

    (@brechtvds)

    Hi again,

    Just updated the plugin to version 1.2.2 which should take care of these issues.

    Brecht

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not Compatible With PHP 7?’ is closed to new replies.