Drag & Drop Featured Image
Not compatible with my theme's built-in image attachment function (5 posts)

  1. gotequity
    Posted 2 years ago #

    Hi Jonathan,

    I came across your plugin after searching for a way to bypass my theme's hard-coded image attachment function (which only registers featured images when uploaded through the post/page editor). This morning I installed to test it out and ran into a few problems...

    1) The drag and drop box did not look anything like the screenshot on your plugin page. It looked similar to the native "select featured image" box with two buttons for selecting or uploading a featured image.

    2) When I tried to drop an image from my computer into the box (while in the post editor), my browser reloaded and just displayed the image (as if I had pasted the image URL directly into my browser bar). When navigating back to the post, the featured image box was empty and no image was set after publishing.

    3) In testing the select image feature, I was able to choose a test image that I had already uploaded to my media library and after publishing the thumbnail successfully populated on my test category page, but the actual image did not pass into the post's designated container for the featured image.

    4) I also tried uploading a new image by clicking the "upload" button within the box but the image I selected fom my computer did not attach or display within the post editor's featured image box. Strangely, when I checked my media library, the file name of the image was listed, but it was shown as an unknown mime type. For some reason WP did not register it as a PNG.

    I've debugged in IE9 and FF to check for script conflicts, thinking it might have to do with incompatible jquery, but suprisingly no errors were generated. The only thing I can attribute this to a built-in function in my that builds galleries through images uploaded in the editor for a specific post.

    Here's a snippit from my function.php that enables this feature: http://pastebin.com/3M8uKYxR

    And here's the hook in my single.php to execute the attachment feature:

    Although this is something that probably falls outside of the scope of providing support for your plugin, I'm really hoping you can shed some light on how to disable or work around this built-in roadblock as it really eats away at my time (typically I publish 75-100+ posts per day). I was excited when I came across your plugin last night, and really want to make it work so I can streamline the steps involved in publishing these posts.

    For refernce, here's a link to the theme I'm using: http://tinyurl.com/ck8cndb

    I wish I could provide the URL to my actual site, but am unable to share it publically because it's used as a private portal for client access only. If you want to take a look, just let me know how to reach you outside of the forum and I'd be happy to send you the link and login credenials.

    Thanks in advance for any assistance you can provide!


  2. Jonathan Lundström
    Plugin Author

    Posted 2 years ago #


    I'm truly sorry for not responding to this issue more quickly. I will definitely look into your problem as soon as possible. Right now the issue is that my computer is broken and I am eagerly awaiting the delivery of a spare part for it.

    As soon as I get my computer back running I will make sure to look into this!

    Best regards,

  3. Jonathan Lundström
    Plugin Author

    Posted 2 years ago #

    Hello again,

    After going through your post again I'm unable to give you a good answer as to why the plugin is not functioning as it should. My best best would be that some other plugin is loading a library that collides with my plugin.

    Could you give me a list of the plugins that you use on your WordPress installation, and could you try loading the browser console while loading the post edit page so see if there are any errors.

    Thanks in advance,

  4. gotequity
    Posted 2 years ago #

    Hi Jonathan,

    Thanks for responding back. I just ran the script debug console in IE9 and no errors were produced from the post edit page.

    Here are the active plugins I'm using:

    Add From Server - http://wordpress.org/extend/plugins/add-from-server/
    AMR Users - http://wordpress.org/extend/plugins/amr-users/
    Anti-Captcha - http://wordpress.org/extend/plugins/anti-captcha/
    Add Local Avatar - http://wordpress.org/extend/plugins/add-local-avatar/
    Category Order & Taxonomy Terms Order - http://wordpress.org/extend/plugins/taxonomy-terms-order/
    Comment Notifier - http://wordpress.org/extend/plugins/comment-notifier/
    Configure SMTP - http://wordpress.org/extend/plugins/configure-smtp/
    Easy Fancybox - http://wordpress.org/extend/plugins/easy-fancybox/
    Export to Text - http://wordpress.org/extend/plugins/export-to-text/
    Gravity Forms - http://www.gravityforms.com/
    Gravity Forms Directory - http://wordpress.org/extend/plugins/gravity-forms-addons/
    Gravity Forms User Registration Add-On - http://www.gravityforms.com/add-ons/user-registration/
    Groups - http://wordpress.org/extend/plugins/groups/
    Login Logout - http://wordpress.org/extend/plugins/login-logout/
    P3 - http://wordpress.org/extend/plugins/p3-profiler/
    Post Category Only - http://wordpress.org/extend/plugins/post-category-only/
    Pretty File List Pro - http://codecanyon.net/item/file-list-pro/2474660
    Q2W3 Post Order - http://wordpress.org/extend/plugins/q2w3-post-order/
    Quick Page/Post Redirect - http://wordpress.org/extend/plugins/quick-pagepost-redirect-plugin/
    Rich Text Tags - http://wordpress.org/extend/plugins/rich-text-tags/
    Role Scoper - http://wordpress.org/extend/plugins/role-scoper/
    Simple Access Control - http://wordpress.org/extend/plugins/simple-access-control/
    Simply Show IDs - http://wordpress.org/extend/plugins/simply-show-ids/
    Theme My Login - http://wordpress.org/extend/plugins/theme-my-login/
    TurboCSV - http://wphostreviews.com/product/turbocsv
    User Role Editor - http://wordpress.org/extend/plugins/user-role-editor/
    W3 Total Cache - http://wordpress.org/extend/plugins/w3-total-cache/
    WCK Taxonomy Creator - http://wordpress.org/extend/plugins/custom-taxonomy-creator/
    WP-Table Reloaded (now TablePress) - http://wordpress.org/extend/plugins/tablepress/

    I am using the most current versions of all plugins and am running WP 3.5.1 for this installation.

    Thanks again for taking a look, and please let me know if I can provide any additional information.

  5. Jonathan Lundström
    Plugin Author

    Posted 2 years ago #


    I've been trying to perform some debugging but it's hard to do it since I don't have it all configured. If you have a working setup and are willing to let me have a look I'd be more than happy to help.

    My goal is to make my plugin work properly without conflicting with other plugins but it's not always easy. You can send me an email at the email listed in the plugin description and we can work something out.

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Drag & Drop Featured Image
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.