Support » Plugin: Media Sync » Not compatible with Multisite WordPress

  • Resolved amirhmoradi

    (@amirhmoradi)


    Hi,
    I cannot use the plugin in a multisite setup. The first thing blocking is that in WPMU, we do not have the update_plugins permission your plugin relies on.

    Is it possible for you to make this plugin compatible with Multisite wordpress environment?
    NB, in wpmu, we can set the upload path setting for each site, but if omitted, the default upload path for a given site_id is :
    <network_root>/wp-content/uploads/sites/<site_id>/

    Best regards.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author erolsk8

    (@erolsk8)

    Hi @amirhmoradi, thank you for the detailed explanation. I’ll try to make that adjustment as soon as I find some time.

    I’ll make an update here.

    Plugin Author erolsk8

    (@erolsk8)

    Hi @amirhmoradi,

    I just pushed new version 1.0.3 which requires import capability (permission) instead of update_plugins.

    Please let me know if it works for you.

    Thanks,
    Erol

    Hi, thanks for your update.
    The plugin installs and runs but cannot find the upload path.
    It adds a duplicate /sites/<site_id> at the end of a supposed uploads path and resulting finally in : /wp-content/uploads/sites/<site_id>/sites/<site_id>

    And so it cannot find any files

    Thanks.

    Plugin Author erolsk8

    (@erolsk8)

    Looks like it’s because WordPress automatically always adds /sites/<site_id> at the end. So adding that part to custom “Upload Path” is not needed.

    In fact, adding it broke uploading to Media Library.

    I tried changing “Upload Path” to: /<full_path>/wp-content/uploads/sites/3, went to default Media Library and uploaded new file. And it was broken (image not found). Then I checked what happened and WordPress itself uploaded it to /sites/<site_id>/sites/<site_id>.

    So as far as I can see, this plugin is consistent with Media Library.

    And to summarise, changing “Upload Path” value from:
    /<full_path>/wp-content/uploads/sites/3
    to:
    /<full_path>/wp-content/uploads
    should fix this issue.

    Tried your suggestion and it works!
    Thanks a lot for your great work and support 🙂

    Plugin Author erolsk8

    (@erolsk8)

    Great! I’m glad I could help 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Not compatible with Multisite WordPress’ is closed to new replies.