Support » Plugin: Lingotek Translation » Not compatible with Elementor

  • It is not compatible with Elementor, it does not maintain the CSS and styles of the web, we have contacted their support twice and have not received any response, they simply ignore us. Very disappointed.

  • The topic ‘Not compatible with Elementor’ is closed to new replies.