Support » Plugin: Contact Form 7 Polylang Module » not compatible with cf7 v5

  • Resolved yopraag

    (@yopraag)


    Hi

    Thanks for the effort on writing this plugin.

    I just installed your plugin and couldnt see my form on the translation page.
    Luckily I have a local backup. I imported the contact form data from my local wordpress but it seems that the form is still not showing even though your plugin is disabled.

    I think you have to add a warning that your plugin is not compatible with CF7 v4.8 and above to the main page of your plugin.

    Thanks,
    Yotam

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Aurovrata Venet

    (@aurovrata)

    Hey Yotam,

    thanks for the heads up. There are actually several extensions that reported issues with cf7 v4.8 and above. Please read my thread on this. However, I have run cf7 4.8/4.9 without any issues on my servers (both dev and live projects) with several extensions I have developed for cf7, but I still haven’t figured out why this is not working properly for other users. I believe it has to do with the way the REST API is setup in the cf7 plugin, but I am not sure as I haven’t got round to doing any projects with REST as yet.

    I just installed your plugin and couldnt see my form on the translation page.

    I am assuming you are talking about the front-end. Are you using a REST theme?

    I imported the contact form data from my local wordpress but it seems that the form is still not showing even though your plugin is disabled.

    that’s very odd, cause my plugin does not actually write anything to the DB that would affect the display of forms once disabled. Is this happening only on the server and not your localhost? Could you check that you are running php 5.6 and greater on your server? Any chance you can get a debug log file from your server to see if there is any issue.

    Also, what is the shortcode you are using to display your form on the front-end? This plugin introduces a unique key based shortcode to make cf7 forms more portable,
    [cf7-form key="contact-us"]

    rather than then cf7 default shortcode

    [contact-form-7 id="4"]

    so if you are using the key based shortcode and disable the plugin, this could be the reason your form is still not showing.

    I am going to run a few tests with the latest version of cf7 and let u know if I see anything obvious.

    Hey

    Thanks for the very quick reply.

    I was actually talking about the back end.
    Not sure why but I installed the plugin and two things happened:

    1. On the admin of CF7 the form dissapeared. The only hint I had was that at the top of the table it showed “Published (1)”

    2. On the polylang settings page the option for translating custom post types for “Contact Form” was already checked. It was also disabled and I could not toggle it.

    Is this happening only on the server and not your localhost?

    Yes, it’s on my server, but I haven’t check to see if this works or not on my local dev.

    Could you check that you are running php 5.6 and greater on your server?

    Im running php 5.6

    Any chance you can get a debug log file from your server to see if there is any issue.

    Possibly, although I don’t have the time to right now.

    Regarding the shortcode, I am using the classic id base but my base language is Hebrew and not English so the key based shortcode might not be a good idea.

    Thanks!

    Plugin Author Aurovrata Venet

    (@aurovrata)

    I been running a few test myself and found some issues which are due to updates in Polylang rather than cf7. I have been meaning to re-write this plugin as an extension to my new plugin CF7 Smart Grid-layout. It is basically a re-write of the cf7 dashboard pages (table and form editor) to use WP std dashboard interface. You can read more about it in this thread. Bottom line is that, with this new plugin, it is a lot easier to enable polylang and other such plugins to play nice with cf7. It also mean less maintenance for me. I should be able to do this sometimes next week hopefully. However, this does not explain why you cannot see your forms.

    1. On the admin of CF7 the form dissapeared. The only hint I had was that at the top of the table it showed “Published (1)”

    I think the reason you cannot see your forms is maybe due to the same issue a user reported on this thread. Are you by any chance viewing your WP dashboard in hebrew, or in another language other than english? If so, would you mind changing to english and see if you have the same problem?

    I am using the classic id base but my base language is Hebrew and not English so the key based shortcode might not be a good idea.

    that shouldn’t make a difference. The unique key is basically the cf7 post slug, so if you are using hebrew slugs for your other posts, it should work for this too. Or you can rename your keys to roman characters.

    Hey @aurovrata

    Thanks a lot for your patience and commitment to this issue.

    CF7 smartgrid seems interesting, I’ll give it a go.

    Regarding your questions:

    Are you by any chance viewing your WP dashboard in hebrew, or in another language other than english?

    The dashboards language is in english. I tried changing the selected language in the polylang menu on the admin but that didn’t make a difference.

    If so, would you mind changing to english and see if you have the same problem?

    See above, the issue occurrs when the admins language is set to english.

    Plugin Author Aurovrata Venet

    (@aurovrata)

    ok, so I am not sure what could be the issue. I would need to get a debug log file to trace the errors. You can activate the debug log by placing the following lines in your your wp-config.php file,

    define('WP_GURUS_DEBUG', true);
    define('WP_DEBUG', true);
    if ( WP_DEBUG ) {
        define( 'WP_DEBUG_LOG', true );
        define( 'WP_DEBUG_DISPLAY', false );
        @ini_set( 'display_errors', 0 );
        define('AUTOSAVE_INTERVAL', 600 );  //seconds
    }
    

    just above the line,

    /* That's all, stop editing! Happy blogging. */

    reload the contact admin page where you are getting the issue and hopefully you should get a file wp-content/debug.log populated with the errors. Please share the file with me via google drive or dropbox.

    Plugin Author Aurovrata Venet

    (@aurovrata)

    I did some testing this we and realised that Polylang v2.3. is has changed a few things which breaks the plugin.

    I am gong to re-write parts of this plugin to leverage the CF7 Smart Grid extension WP-compliant admin pages form table and editor, this way this kind of issues with updates in Polyang will be less frequent, as Polylang assumes WP-std dashboard integration, and till now this plugin has had to rely on some not very nice way to get Polylang and CF7 to play nice.

    So, until the next release of this plugin, I request you to please downgrade to the last version of Polylang 2.2: https://downloads.wordpress.org/plugin/polylang.2.2.8.zip to continue to use this plugin.

    I hope to have new version by the end of this month or early next month. Thank you for your patience.

    Plugin Author Aurovrata Venet

    (@aurovrata)

    @yopraag, v2 released a few days back now fixes all the issues with polylang v2.3 that you reported. You’ll need to install the CF7 Smart Grid extension to keep using this plugin.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘not compatible with cf7 v5’ is closed to new replies.