Support » Plugin: (Simply) Guest Author Name » Not compatible with Amp validation

  • Resolved zarboss

    (@zarboss)


    I have problems with your plugin but I think everyone. One problem is that you don’t see the guest author but the biggest problem is that the pages are not amp compatible and give validation errors. This is unthinkable because Amp is becoming an essential protocol.
    The error is: An invalid layout is specified in the AMP HTML tag attributes.
    Best regards
    Paolo

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Thread Starter zarboss

    (@zarboss)

    Thanks a lot to you. Have a good weekend. Regards

    Plugin Author Shoofly Solutions

    (@nomadcoder)

    This is a compatibility issue between the two plugins. I was able to fix it so that the image displays. I would need to get in touch with the developer of this AMP plugin to add a filter the author name.

    Thread Starter zarboss

    (@zarboss)

    I have tried other plugins like yours but none have adapted, indeed these have created problems for me. Your plugin is the best. Amp deletes all scripts so it stands to reason that it doesn’t work. I have tested that your plugin is the best but for now I can not use the guestauthor because with the errors google does not index posts. So it’s bad for me that I have a newspaper.
    Thanks for your appreciate help.
    I want to remind you Amp is the future mobile perspective at this moment.
    Regards

    Plugin Author Shoofly Solutions

    (@nomadcoder)

    I am in touch with them and expect this to be resolved soon.

    Plugin Author Shoofly Solutions

    (@nomadcoder)

    Hello, I have received guidance from AMP support. Let me know if the latest update resolves your issue.

    Thread Starter zarboss

    (@zarboss)

    Now the name guestauthor shows up and works. I personally have only one mistake on: The mandatory attribute ‘width’ is missing in tag ‘amp-img’.
    I think that the problem at this point is the theme, because from the analysis I do not see the image that gives the problem. However, if it can help you I don’t see any avatar image on amp but only the name. Thank you for your great job.
    Regards Paolo

    Plugin Author Shoofly Solutions

    (@nomadcoder)

    Please test with the twenty twenty theme! I am getting the image.

    As for the amp-img tag, I will take another look at that. I am not sure that the HTML is coming from the plugin.

    Plugin Author Shoofly Solutions

    (@nomadcoder)

    Hello,

    Let me know if the latest update fixes the attribute issue. I am getting the image in my test environment, but have made some changes.

    If you still are not getting the image, please test with another theme.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.