Support » Plugin: Nav Menu Roles » Not Compatible with 3.5.1

  • This is the error message I get after activating this plugin:

    Warning: Missing argument 2 for Nav_Menu_Roles::edit_nav_menu_walker() in /home/content/27/9233427/html/wp-content/plugins/nav-menu-roles/nav-menu-roles.php on line 91

    I can see the logic in the menu area which is great, but it will not display the menu according to the user role.

    I hope you are able to fix this issue. It will be a very powerful fix for many web-developers of wordpress.

    It also conflicts with other plugins, i.e. SlideDeck2, which will also be an obstacle to overcome.

    http://wordpress.org/extend/plugins/nav-menu-roles/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author helgatheviking

    (@helgatheviking)

    Thanks for pointing this out. I will look into it.

    Until WP adds some hooks in the admin for adding my checkboxes without overriding the entire admin menu Walker, unfortunately it is going to conflict with some plugins.

    Plugin Author helgatheviking

    (@helgatheviking)

    I cannot reproduce this error on my server. Do you still get it if you disable your other plugins? And/or if you revert to the default theme?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Not Compatible with 3.5.1’ is closed to new replies.