Support » Plugin: Swift Performance Lite » Not caching

  • badscooter1980

    (@badscooter1980)


    I seem to be having a similar issue as before where this caching plugin isn’t working.

    Everything is configured as it should be, yet the plugin does not cache anything unless I manually cache each page.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Fred

    (@fredawd)

    Hi,

    Maybe there is another cache layer active or Curl might be disabled.
    Can you tell us a bit more about your server? Is it Apache, NGINX, etc.

    badscooter1980

    (@badscooter1980)

    Hi,

    Linux, Apache.

    There are no other caching plugins active and Curl/HTTP Loopbacks are also enabled.

    Plugin Contributor Fred

    (@fredawd)

    If I`m right, your hosting use Edge Caching for Speed and that´s preventing Swift from caching your site.

    badscooter1980

    (@badscooter1980)

    Hi,

    Interesting, as Zircle.co.uk, plantsforeurope.com and aeromobile.net are on the exact same platform, and all seem to be working just fine.

    Plugin Contributor Fred

    (@fredawd)

    The only way to find out is to disable it (temporary) in WordPress General Settings
    Cache Level: disable

    badscooter1980

    (@badscooter1980)

    I’m not sure where you are referring to? There is no ‘cache level’ in the WordPress general settings control panel?

    Plugin Contributor Fred

    (@fredawd)

    Well, maybe there is a different setup. W`re no familair with Edge cache. You could also disable caching in Swift and only use other features, eg merge Scripts, merge Styles…

    badscooter1980

    (@badscooter1980)

    Hi Fred,

    From my hosting company;

    “Thanks for your patience.

    I’ve conversed with our system administrators in relation to this and can confirm that on the Linux Platform, caching does not take plac, if we cache content we will insert the ‘x-cache-status’ http response header to be absolutely sure and we cannot see that this is happening here.

    We can see that the requests are being made to the webserver, here is a loadbalancer log to indicate this

    Feb 22 11:15:42 l4lb-133.ptl.stackcp.net haproxy[27158]: 109.69.82.40:60233 [22/Feb/2019:11:15:42.644] l4proxy-plain~ l7balancers/l7lb9.ptl.stackcp.net 0/0/0/26/29 200 24469 – – —- 533/533/89/41/0 0/0 {www.philltarling.com} “GET /wp-content/plugins/swift-performance-lite/css/styles.css?ver=2.0.6 HTTP/1.1”
    Feb 22 11:15:42 l4lb-133.ptl.stackcp.net haproxy[27158]: 109.69.82.40:60233 [22/Feb/2019:11:15:42.643] l4proxy-plain~ l7balancers/l7lb9.ptl.stackcp.net 0/0/0/32/32 200 1114 – – —- 532/532/87/39/0 0/0 {www.philltarling.com} “GET /wp-content/plugins/swift-performance-lite/includes/luv-framework/plugins/codemirror/theme/monokai.css?ver=b8f4f5093140b2c449d28459c6088d12 HTTP/1.1″

    The server configuration is the same as your other sites and we can only narrow this down for the developers to look into. If there is anything we need to do on our side, please let us know and we’ll see what we can do.”

    Plugin Contributor Fred

    (@fredawd)

    Hi,
    To be honest, it is not easy to solve this from here. Due to WP forum rules we are not allowed to offer login and take a closer look into this issue.

    Anyway, in HTTP header I see that Swift is failing. Most likely there will be a plugin conflict or a pseudo query string. You might disable all plugins and reactivate them one by one, to find the conflicting plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.