Support » Plugin: Super Page Cache for Cloudflare » Not Caching

  • Resolved brightonseo

    (@brightonseo)


    Returning cache arror:
    Error on dynamic page (https://: Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

    Error on static resource (: Seem that your website is not behind Cloudflare. If you have recently enabled the cache or it is your first test, wait about 30 seconds and try again because the changes take a few seconds for Cloudflare to propagate them on the web. If the error persists, request support for a detailed check.

    • This topic was modified 1 year, 3 months ago by brightonseo.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Saumya Majumder

    (@isaumya)

    Hi @brightonseo,
    When testing your website I see that the Cloudflare is not caching your pages cause each of your pages has a lot of custom cookies in the header. Screenshot: https://i.imgur.com/DXlzHtK.png

    Please note that when Cloudflare sees any custom cookies in the response header, it thinks that the page content might be dependent on the cookie value and hence doesn’t cache the page.

    So, you can either remove the plugin which is adding all these cookies in every single page or you can enable the “Stripe Response Header” option inside this plugin setting (Cache Tab) and then test your website thoroughly to ensure your site is working perfectly with the cookies removed from the Response Header.

    Thread Starter brightonseo

    (@brightonseo)

    Thanks Saumya

    I tried your solution and it got it workingg perfectly.
    I also tried it on another site that had a similar issue and it fixed it too.

    Many thanks for the help and the excellent support for such a neat blazing fast plugin. 🙂

    • This reply was modified 1 year, 3 months ago by brightonseo.
    • This reply was modified 1 year, 3 months ago by brightonseo.
    Thread Starter brightonseo

    (@brightonseo)

    This issue is now fixed.

    Plugin Contributor Saumya Majumder

    (@isaumya)

    Thanks for confirming @brightonseo. Enjoy the plugin. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not Caching’ is closed to new replies.