WordPress.org

Support

Not backing up due to SSL?

  • I just implemented SSL on one of my sites and now the database backup is not working.

    The SSL is the only thing that changed since the last backup which was successful.

    What happens is that I see a black box after I click “Run Now” and no text is outputted; it just stalls a while and makes me nervous until I stop it from “running”. I am attempting to send the database backup to my Dropbox account.

    One of the issues that I have with the SSL at the moment is that my domain email is not working properly and that needs to be fixed. Perhaps that is creating a conflict with the program.

    If I am behind SSL, do I have to put my username and password in the last box in Settings (HTTP Authentication)? I tried that and it still didn’t work right.

    I tested it on another blog at a different host that is not behind SSL and it ran fine and quickly. So, that is why I suspect SSL is creating the issue on this host.

    Any suggestions on how to fix this?

    http://wordpress.org/extend/plugins/backwpup/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Daniel Hüsken

    @danielhuesken

    Hi,

    SSL normely works. In moment i can only help if we integrate a test in a file to see waht happend.

    the test is:
    in backwpup/job/job_start.php on (on the ens) line 241 chage it to:
    $res=wp_remote_post($backwpup_static['JOBRUNURL'], array('timeout' => 3, 'blocking' => true, 'sslverify' => false, 'headers'=>$httpauthheader ,'body'=>array('nonce'=>$backwpup_working['NONCE'], 'type'=>'start'), 'user-agent'=>'BackWPup'));
    and after that line add a line with:
    print_r($res)

    Than i ned the massage that cams on top if the job startet manualy.

    Never mind … posted questions below.

    Is the following code supposed to be in the script?

    => ‘Basic ‘.base64_encode($backwpup_static[‘CFG’][‘httpauthuser’].’:’.backwpup_base64($backwpup_static[‘CFG’][‘httpauthpassword’])));

    If not, maybe that is the problem.

    I found the wp_remote_post section but it does not have $res= in front of that so I guess you want me to add that.

    So, this is how it should look (with my changes in bold)?

    $res=wp_remote_post($backwpup_static[‘JOBRUNURL’], array(‘timeout’ => 3, ‘blocking’ => false, ‘sslverify’ => false, ‘headers’=>$httpauthheader ,’body’=>array(‘nonce’=>$backwpup_working[‘NONCE’], ‘type’=>’start’), ‘user-agent’=>’BackWPup’));
    print_r($res);
    return $backwpup_static[‘LOGFILE’];
    }

    Please advise before I make the change. Thanks.

    Actually, it seems that you also want me to change ‘blocking’ => false to true

    Plugin Author Daniel Hüsken

    @danielhuesken

    Yes thats are the cahnges. To get a output.

    Okay, this is the error message that I am getting:

    WP_Error_Object [errors] => Array ([http_request_failed] => Array [0] => connect () timed out!)) [error_data} => Array () )

    Does this sound like a memory issue?

    Plugin Author Daniel Hüsken

    @danielhuesken

    No not a memory issuse only a connection time out. has the job started after the massage ?

    you can try to increase the ‘timeout’ => 3 to test if it than works. Try 20

    Okay, I upped the timeout to 20 and it still does not work and produces the same error message.

    I still think it has something to do with adding SSL to my domain.

    I really like this program and wish it would work. : (

    Any other ideas?

    Plugin Author Daniel Hüsken

    @danielhuesken

    in Version 3 we have chande many that can help but it cames out in the end of jannuary we hope.

    Thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not backing up due to SSL?’ is closed to new replies.
Skip to toolbar