Support » Plugin: Post to Google My Business » Not automatically posted to GoogleMyBusiness

  • Resolved 101010tech

    (@101010tech)


    After posting a new article,
    this message is displayed and it is not automatically posted to GMB.
    「No posts found. The posting process may still be in progress, or no location was selected.」
    If automatic posting is be in progress, How long is the time interval for automatic posting?

    • This topic was modified 3 months, 1 week ago by 101010tech.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter 101010tech

    (@101010tech)

    As a side note, I created WordPress posts using WordPress’s REST API.

    Plugin Contributor Koen Reus

    (@koen12344)

    Does it work when you manually create a post through the metabox, or turn on the auto-post toggle and then Save/Update the WordPress post?

    If you’re on the premium version, also make sure you have selected a location under the “Advanced post settings” in the auto-post template (Post to GMB > Settings > Auto-post settings).

    If you are in fact using the premium version, please contact me at koen@tycoonwp.com for further assistance as the support section here is only meant for the free version of the plugin.

    ~ Koen

    Thread Starter 101010tech

    (@101010tech)

    Thank you for your reply.

    > Does it work when you manually create a post through the metabox,
    > or turn on the auto-post toggle and then Save/Update the WordPress post?
     The cause is unknown, but sometimes it works and sometimes it doesn’t if I turn on the auto-post toggle and then Save/Update the WordPress post.

    I’m sorry, I’m using the free version of the plugin.

    Plugin Contributor Koen Reus

    (@koen12344)

    Do you know how to access the server error log? Maybe check if there is an error related to the plugin immediately after a post is not being published to your GMB listing.

    Sounds like something is making the posting process fail. The post should go out to GMB (almost) immediately.

    Thread Starter 101010tech

    (@101010tech)

    Thank you for your reply.
    As a result of checking PHP error with a plugin「QueryMonitor」, the following error was output.

    ——————————————————
    【message】
    Undefined property: stdClass::$locality

    【detail】
    wp-content/plugins/post-to-google-my-business/src/Components/BusinessSelector.php:116
    PGMB\C\BusinessSelector->location_data_column()
    wp-content/plugins/post-to-google-my-business/src/Components/BusinessSelector.php:88
    PGMB\C\BusinessSelector->location_rows()
    wp-content/plugins/post-to-google-my-business/src/Components/BusinessSelector.php:58
    PGMB\C\BusinessSelector->account_rows()
    wp-content/plugins/post-to-google-my-business/src/Components/BusinessSelector.php:26
    PGMB\C\BusinessSelector->generate()
    wp-content/plugins/post-to-google-my-business/inc/class-mbp-admin-page-settings.php:200
    MBP_Admin_Page_Settings->settings_field_google_business()
    wp-admin/includes/template.php:1743
    do_settings_fields()
    wp-admin/includes/template.php:1701
    do_settings_sections()
    wp-content/plugins/post-to-google-my-business/src/WeDevsSettingsAPI.php:539
    PGMB\WeDevsSettingsAPI->show_forms()
    wp-content/plugins/post-to-google-my-business/templates/settings.php:6
    MBP_Admin_Page_Settings->admin_page()
    wp-includes/class-wp-hook.php:303
    do_action(‘toplevel_page_post_to_google_my_business’)
    wp-admin/admin.php:259

    • This reply was modified 3 months, 1 week ago by 101010tech.
    Plugin Contributor Koen Reus

    (@koen12344)

    That’s an unrelated error unfortunately, but one that has to be fixed regardless 😅 Taking note!

    I doubt you will be able to see the error (if any) using the QueryMonitor plugin as the post publishing process runs in the background.

    The only way to see it will be through the server error log, which should be accessible through the Cpanel of your webhost.

    Thread Starter 101010tech

    (@101010tech)

    Thank you for your reply.
    As a result of checking Server errorlog, the following error was output.

    ——————————————————
    [23-Aug-2021 12:35:31 UTC] PHP Fatal error: Uncaught Error: Call to undefined function PGMB\download_url() in /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php:243
    Stack trace:
    #0 /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php(271): PGMB\ParseFormFields->get_file_size_from_download(‘http://broad-ar…’)
    #1 /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php(258): PGMB\ParseFormFields->get_remote_file_size(‘http://broad-ar…’)
    #2 /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php(199): PGMB\ParseFormFields->get_local_file_size(‘2021/08/2021082…’, ‘http://broad-ar…’)
    #3 /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php(161): PGMB\ParseFormFields->validate_wp_image_size(161)
    #4 /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to- in /home/users/2/chu.jp-5693/web/wp-content/plugins/post-to-google-my-business/src/ParseFormFields.php on line 243

    Plugin Contributor Koen Reus

    (@koen12344)

    Yup that’s definitely the one! Thanks for checking.

    I’ll see if I can release a quick update to fix the issue!

    Thread Starter 101010tech

    (@101010tech)

    Thank you for confirmation.
    I look forward to hearing from you about the update to fix the issue.

    • This reply was modified 3 months, 1 week ago by 101010tech.
    Plugin Contributor Koen Reus

    (@koen12344)

    Can you try the 2.2.45 update and see if that fixes it? It should fix the other error you posted as well.

    ~ Koen

    Thread Starter 101010tech

    (@101010tech)

    I was able to confirm that the error was not logged.
    Thank you for your support!!

    Plugin Contributor Koen Reus

    (@koen12344)

    Great, thanks for following up!

    nungtirta

    (@nungtirta)

    Hi Koen, I use premium plugin, and find that the post not shows in GMB, i believe you could help.

    Error in cpanel as below:

    [Mon Oct 25 23:49:53.297191 2021] [:error] [pid 14562] [client 203.118.156.153:64374] [client 203.118.156.153] ModSecurity: Warning. Match of "pmFromFile path_excludes" against "REQUEST_FILENAME" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/007_i360_4_custom.conf"] [line "264"] [id "77140992"] [msg "IM360 WAF: Suspicious access attempt (WP folders)!||SC:/home/arandeeco/public_html/wp-admin/options.php||T:APACHE||REQUEST_URI:/wp-admin/options.php||"] [severity "NOTICE"] [tag "service_i360custom"] [tag "noshow"] [hostname "www.arandee.co.nz"] [uri "/wp-admin/options.php"] [unique_id "YXaL0eOowMQOe5lJg4gjnAAAAAo"], referer: https://www.arandee.co.nz/wp-admin/admin.php?page=post_to_google_my_business

    Plugin Contributor Koen Reus

    (@koen12344)

    Hi @nungtirta,

    Looks like a security suite called “IMUNIFY360” on your web server is inadvertently blocking the plugin connection. I’m not familiar with it, but I’d show your web host or web developer the error and I’m sure they will be able to fix this for you.

    The plugin needs to be able to access the following domains and IP addresses:

    util.tycoonmedia.net
    136.144.128.71
    2a01:7c8:fff9:f6::3

    app.posttogmb.com
    216.239.32.21
    2001:4860:4802:34::15

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.