Support » Plugin: Twitter Tools » Not automatically downloading tweets

  • I’ve been checking every morning and since the upgrade Twitter Tools is not automatically downloading tweets; when I click the button some number of tweets are downloaded. This is in addition to the incredible slow upgrade that I’m seeing. It appears on the face of it that the cron or other time-based code (haven’t looked in the code yet) isn’t working properly. If someone suggests what to check I’ll check and provide the info back here. Thanks!

    http://wordpress.org/extend/plugins/twitter-tools/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Justin Sternberg

    (@jtsternberg)

    The plugin is not downloading any tweets for me. I upgraded to the new version and converted all the tweets over. But it hasn’t imported any tweets since 10-10-2012. I’ve tried manually clicking the “Download Tweets Now” button and then it gives me the message, “Tweets are downloading… ” but nothing actually happens. What am I missing?

    Justin Sternberg

    (@jtsternberg)

    Ok, just found the answer in another support thread: http://wordpress.org/support/topic/plugin-twitter-tools-social-dependence?replies=29#post-3254542

    from the the thread:
    “Alex: I would recommend making it clearer that in the Twitter Tools settings you have to click on the particular rectangular box for the Twitter account to actually enable it! I finally discovered it after a lot of delving around when I finally found this thread.

    Of course now that I *know* I have to do that, it’s stunningly obvious :)”

    electricbob

    (@electricbob)

    I have turned things on – I found that forum post also the day after the new version was released. It’s just not automatically updating, and I suspect the upgrade is also only doing one or two passes and then stopping. I don’t know what to check ….

    Jeffrey Keefer

    (@jeffreykeefer)

    I find the same thing, my posts do not appear to be automatically downloading either.

    I have both Enable Twitter Tools and Create blog posts from tweets checked, and while they do come down when I click the Download Tweets Now button, I have to click the button for this to happen.

    I am using 3.0.3 and Social 2.6 on WP 3.4.2.

    Thank you.

    Justin Sternberg

    (@jtsternberg)

    Ok, having the same problem. I need to manually click the button for them to import. Any solutions?

    davidkingsbury

    (@davidkingsbury)

    Same for me – I keep checking after each update to Twitter Tools and Social, but the 15 minute cron job just doesn’t seem to fire. The account is enabled and works fine when manually downloading via the button – it just doesn’t automatically check…

    Plugin Contributor Alex King

    (@alexkingorg)

    Social and Twitter Tools rely on the built-in WP Cron system. You may need to look into the various debugging steps for that (site can load itself, etc.).

    bhesk@hotmail.com

    (@bheskhotmailcom)

    Same problem for me.

    Running WP 3.4, Social 2.6 and Twitter Tools 3.03. All of this on top of WAMPServer 2.1.

    Manually downloading tweets works fine. Scheduled download never works.

    WP-Cron jobs are set up. Social is configured to run every 15 minutes.

    I’ve run some debugs on both Twitter Tools and Social, and see this in the event log if I try and run the Social cron job manually:

    {SOCIAL – 2012-11-01 15:44:56 – 10.1.200.7] Running cron_15_init
    [SOCIAL – 2012-11-01 15:44:56 – 10.1.200.7] Running request: CRON/action_cron_15
    [SOCIAL – 2012-11-01 15:44:56 – 10.1.200.7] Attempting semaphore lock
    [SOCIAL – 2012-11-01 15:44:56 – 10.1.200.7] Semaphore lock failed. (Line 40)

    I suspect this is the cause of the problem. Now I just need to work out how to fix it 🙂

    Plugin Contributor Alex King

    (@alexkingorg)

    Can you check in your wp_options table to see if you have rows with any of these keys?

    – social_last_lock_time
    – social_locked
    – social_unlocked

    electricbob

    (@electricbob)

    Yes I can 🙂

    social_last_lock_time == 2012-11-02 20:14:28
    social_locked == 1
    social_unlocked not present

    Thanks! – Bob

    bhesk@hotmail.com

    (@bheskhotmailcom)

    And for me

    social_locked 1 yes
    social_last_lock_time 2012-11-01 14:42:10

    No key value for “social_unlocked”.

    Hope this helps. Thanks for posting.

    Barry

    Plugin Contributor Alex King

    (@alexkingorg)

    Looks like the lock may not be breaking correctly – try deleting both of those options and see what happens.

    electricbob

    (@electricbob)

    I have tried this, and I tried turning Twitter Tools off and back on via settings – no auto update. When I force an update I get a value for social_last_lock_time, however, I now never see social_locked or social_unlocked. Thanks! – Bob

    Jeffrey Keefer

    (@jeffreykeefer)

    Can you give some guidance where I should look for the wp_options table? That may be a bit more technical than I know where to look.

    BTW, when I click to update the Tweets, they all still update nicely; I just have to remember to do it once or twice a day.

    Thanks.

    Jeffrey

    electricbob

    (@electricbob)

    It’s one of the tables in your WordPress MySQL installation (well, mostly likely MySQL :-). If you have a hosted account, it’s like your provider has phpMyAdmin or something similar.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Not automatically downloading tweets’ is closed to new replies.