Support » Plugin: Email Subscribers & Newsletters » Not always sending notification with new post

  • Resolved Harris_S

    (@harris_s)



    Love the plugin. However it occasionally does not send an email to subscribers when I post a new post. Not sure why. Does not show as having sent an email under the ‘sent emails’ tab. Would be nice to be able to send an email to subscribers when one is not sent, i.e., like a ‘resend’ except there is not one listed under the ‘sent emails’ – so would be nice to click on a post, and have an option to ‘resend’ or ‘send’ to subscribers.

    https://wordpress.org/plugins/email-subscribers/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author storeapps

    (@storeapps)

    Hi,

    With regards to ‘resend’ option to re-send the mails, we have noted down your valuable suggestion and will surely consider implementing the same in future versions.

    Also, with regards to occasionally not sending an email to subscribers, you can check if the emails are getting bounced back by looking into email log file (you can ask your Host Provider to give it to you) and get back to us.

    Thank you for your response.

    I do not need to check whether the emails are getting bounced because I see that they are not listed in the “Sent Mails” tab. In other words, it is not as if they are being sent by Email Subscriber and not being received, but that Email Subscriber is not sending them after a new post is published – as mentioned, an intermittent problem.

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Can you please confirm if you have followed all the steps mentioned here – Configure notification email to subscribers when new posts are published.

    If yes, then kindly write to us from here so that we can investigate into the issue further.

    Yes I have. I would think that if I did not, it would not send any notifications at all?

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Can you please check that the new post that you are publishing, that category is checked under the Notification tab? Because if that category is not checked, then post published to that category won’t be send to subscribers.

    Also, we are unable to reproduce the same issue at our end. So, can you please tell us steps to reproduce the issue by writing a support simply from here.

    Aha!
    Thanks for solving the problem. This is where the problem was. But I would like to suggest that you code so that when a new category is created, it is automatically added. My rationale is this, assuming that other people work the way I do: I write the post, either use a pre-existing category or create a new one, and when the post is completed, publish. I may first save as a draft. However, the way the routine now works means that a user would have to write the post, create the new category, save as a draft, then go to Email Subscribers, include the category, come back to the draft post to then publish.

    Thanks for solving the problem!

    Plugin Author storeapps

    (@storeapps)

    Hi,

    You are welcome! Glad to hear it is working now.

    Also, with regards to auto adding category when a new category is created, we have noted down your suggestion and will consider implementing the same in future releases of Email Subscriber.

    Thank you for your prompt responses to my posts, helping to understand the reason for the problem I was experiencing, and your willingness to consider my suggestions. Much appreciated. Have a great 2016!

    Plugin Author storeapps

    (@storeapps)

    Hi,

    Thank you for your kind words! It means a lot to us 🙂

    If you like our plugin, please consider leaving us a 5-star rating.

    Wishing you a great 2016 🙂

    Hi, seems like another bug has appeared.
    I posted a new article and no notification was sent. Three categories were checked, all previously used. Checked the ‘Notification’ and all categories included. However, when clicking ‘Edit’, only one of the 120 categories I have is selected, i.e., all the others that were previously selected when I last checked, have become de-selected. Very strange.

    Considering that some people, like me, have many categories, it would be nice to have a button that ‘selects all’ for it is a pain to have to click each one!

    Plugin Author storeapps

    (@storeapps)

    Hi,

    All categories getting de-selected on its own? Strange.
    Can you please try publishing another new post and check if the same issue happens again?

    Also, we will surely consider adding ‘select all’ checkbox in future releases.

    Will check and let you know. Thanks again.

    Plugin Author storeapps

    (@storeapps)

    @harris_s,

    Please update to Email Subscribers v3.1.5 as it has Check All & Uncheck All button to select all categories while creating notifications.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Not always sending notification with new post’ is closed to new replies.