Support » Plugin: WP-Members Membership Plugin » Not Allowing Logins

Viewing 13 replies - 16 through 28 (of 28 total)
  • the wp-members can be found under ‘settings’ in the dashboard.

    hello chad yes i see it.
    – no the user dont using incorrect password because i change it and nothing.
    – the final month November i dont change moderated registration
    – and i use the recaptcha nothing else

    Hi Chad! I love your plugin. Hope what I did will permanently fix the problem.

    wp-members and this http://wp-member.com/
    it is the same?
    I try to find a plugin which i do my job without problems and when i want i have a full support.

    Sorry know nothing about it.

    I only use Chad Butler’s WP-Members.

    http://rocketgeek.com/

    Plugin Author Chad Butler

    (@cbutlerjr)

    @susie.Q – thanks for the comments – I’ll look into this as I am able today. There are no issues specific to upgrading to 4.0.1. I’ve even upgraded the premium support site to it and have had no issues.

    @grigoris – if you need/want the priority support service you subscribed to, you need to respond to that ticket with the additional requested information. Timely support requires that you keep things in the appropriate thread otherwise I can’t get to them in a timely manner; so rather than insulting the service, maybe you could help a little bit by getting the info to me in the original email support ticket you opened so I don’t have to go around looking for it?

    Chad i m sorry but i have problem.
    it is not working.
    If i send my admin settings could you please to see what it is wrong?
    ‘Please help me

    Plugin Author Chad Butler

    (@cbutlerjr)

    @susie.Q –

    1. In your dashboard go to ‘Settings>General’ and make sure ‘Anyone can register is UNCHECKED.

    2. In the WP-Members Options, I UNCHECKED the ‘Hide Registration’ box.

    These would be unrelated to your issue.

    3. I read on line that sometimes caching pages for plugins that force login to the front end like WP-Members does can cause a problem.

    I use WP Super Cache so in †he WP-Super Cach Settings>Advanced settings I added the strings for the WP-Member pages that force those pages not to be cached,ex. /register/, /members-area/, /sign-in/

    Of anything you’ve mentioned, this is the only thing that would probably be your issue. While WP Super Cache shouldn’t cause any issues with login, it certainly could be possible depending upon your configuration.

    4. If you are using something other than the recaptcha that is suggested in the WP-member settings, you may have to deactivate †hat plugin as it may cause a conflict.

    WP-Members has built in support for reCAPTCHA and Really Simple CAPTCHA for registration. But these would be unrelated to login. If you use a plugin that incorporates a CAPTCHA into the backend login (wp-login.php), then that will most likely cause a problem.

    That particular problem stems from the fact that these plugins remove the wp_authenticate_username_password function from the authenticate process and replace it with their own. That creates a problem because they add a third level of authentication (username, password, AND captcha) to WP’s autheticate process, which WP-Members also uses when validating a login. But the front end login won’t be passing that third value and will then fail (that is what @grigoris‘s problem was).

    There are no issues with WP 4.0.1 and WP-Members. There’s nothing in the update that effects the plugin.

    Thanks Chad.

    I have been using Captcha for several years with it disabled for login, registration, and resetting password but activated only for the comment form and it hasn’t caused any problems.

    I use just the reCaptcha that comes with your plugin for registration, login, and password reset.

    Changing the WP Super Cache plugin so i† doesn’t cache the pages with WP-Members shortcode seems to have solved the problem.

    I too have a similar problem. I have temporarily fixed it by disabling the plug-in Captcha by BestWebSoft. I have submitted a support ticket to BWS and I am hoping that both developers can work together on this to fix the bug.

    OK, I have now installed BestWebSoft’s other plug-in Google reCaptcha and this seems to work quite happily with WP Members… which I have also used with a reCaptcha setting in it.

    Plugin Author Chad Butler

    (@cbutlerjr)

    I too have a similar problem. I have temporarily fixed it by disabling the plug-in Captcha by BestWebSoft. I have submitted a support ticket to BWS and I am hoping that both developers can work together on this to fix the bug.

    It’s not a bug, and there’s no need to submit a ticket to BWS. Their Captcha plugin enables a captcha on the login by default. All you have to do is uncheck the box in that plugin’s settings that enables the captcha on the login.

    OK, it’s time to revisit this again, because it’s a problem once more.

    This is what I need…

    * captcha or similar on the normal wp dashboard login
    * wp-members with or without captcha but working!

    …but if I use any of the following plugins, then the wp-members log-in pages fail…

    * captcha by bws
    * google captcha recaptcha by bws
    * goodbye captcha
    * various others

    Is there a plug-in that I can use to provide an extra layer of security on the standard wp dashboard login?

    I already have wordfence.

    Thank you,

    Paul

Viewing 13 replies - 16 through 28 (of 28 total)
  • The topic ‘Not Allowing Logins’ is closed to new replies.