Support » Plugin: User Rights Access Manager » Not Allowed Access

  • Resolved knms5525

    (@knms5525)


    I have a user with editor role. I’ve installed this plugin and created a restriction for this user. No matter the settings I try when I login with this user all i see is “Sorry, you are not allowed to access this page”. Please advise, I must be missing a setting somewhere.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    You can set restrictions only for the access pages. The editor can only manage posts and pages. So you can restrict only for that. If you want to restrict them for other menus, then you can change their user role.

    Let us know if you have further queries.

    I had same problem. So I set the user role to “URAM guest” and set the role permition and it works. It is nowhere written that it should be “URAM guest”, but logic.

    Now I set the permition to user, but alway get “Sorry, you are not allowed to access this page.” doesnt matter what is set, even full access. So I delete the role restriction and result is same.
    So user restriction doesnt work for me, independence of settings.

    Am I missing somethig?

    • This reply was modified 6 months, 2 weeks ago by zbojnik.
    Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    Hello @zbojnik,

    You can add a restriction to admin for the backend access. If you are trying to restrict subscription users for backend access, you can restrict user capabilities only.

    You can try setting user access for any other admin user and checking the functionalities.

    Let us know if you are facing the same issue.`

    Hi,
    still same problem.
    It doesnt metter what role has user set. Nor Admin, nor URAM guest.
    If I set any restriction or none to user, always get “not allowed access”.
    Only restriction to role works.

    Hi, any update?
    The problem still persists.

    If I set anything (restriction or permission) to user, the user cannot login. Always get “Sorry, you are not allowed to access this page.”
    Role restriction works.

    Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    Hello @zbojnik

    Can you please share the screenshot of the user setting page? So we can make the same setting from our end to fix that issue because we didn’t face that issue from our end.

    Thanks

    Hello. That’s the problem for me too. I’m using WordPress 5.9. woocommerce plugin: “Sorry, you can’t access this page while editing your order.” fault. Thanks in advance for your help. Sorry for the poor English!

    Hi,
    it doesnt metter what restriction is set. I have all alowed.
    As I wrote before:
    If I set anything (restriction or permission) to user, the user cannot login. Always get “Sorry, you are not allowed to access this page.”
    If I set restriction to role and delete user restriction, it works and can login.

    BR

    Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    Hello @informatikus01 & @zbojnik

    Sorry for the late response. We have fixed that issue and release the new version. You may check it on your end.

    Thanks,

    Hello ,

    Kindly note that I faced the same problem in user permission,
    once I added a user, even without any restriction information whem the user login we have a page of “Sorry, you are not allowed to access this page.”

    Hope to manage this issue

    We’re still having the same issue with woocommerce. When we have set an user-restriction we always get an access denied error when we’re opening the order.

    Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    @pierre0rmayle and @sebastian003 Please change your user role to admin and recheck. Maybe your current user doesn’t have access to that page based on their user role. The plugin restricts pages that have default access based on their user role.

    Hi @miteshsolanki, that still does not work. We’re still getting the error when we’re visiting an order.

    Plugin Contributor mitesh.solanki

    (@miteshsolanki)

    @sebastian003 Did you change the user role to an administrator?

    Yes, the user is an administrator.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.