Support » How-To and Troubleshooting » Not all urls are friendly in wordpress!

Not all urls are friendly in wordpress!

  • hi
    it seems that wordpress does not make all the urls search engine friendly,even if i use custom permalink structure /%postname% ,it still ads weird stuff in url ,example here http://www.celebritymeet.net/lindsay%E2%84%A2-%E2%80%98i-don%E2%80%99t-drink-you-guys%E2%80%99.html

    i don’t understand why it is addin those characters in the url . i checked the .htaccess file and the rewrite rules are present

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    any tip (this is happening on all the sites i have) ?

    thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • Phil


    Try setting your permalinks to ‘custom’, then:


    thanks,but as i said,i already use custom permalink structure,using /%postname% . it makes no difference if i use /%category%/%postname%/

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    When you put strange UTF-8 characters in the title (like ™ or that colon or what have you) then that creates those HTML entities as characters. This usually happens when you are using a third party post editor of some sort. WordPress itself tries to filter that stuff out when entering a post directly, but adding a post through some other service or program means that the other program chooses the slug.

    Just edit your slug on that post to not have those characters in it. Edit the post and click on the Permalink at the top to change it to whatever you like.

    thanks for the reply . i do not use any editor ,that’s why i don’t understand why wordpress is not able to filter those characters . yes,i can edit the slub,but when posting a lot that can be a problem,loosing time to remove the characters .
    maybe this is a problem in wordpres ,or i am the only one who has this problem ?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Not all urls are friendly in wordpress!’ is closed to new replies.