Support » Plugin: Easy Forms for Mailchimp » Not all texts are translated?

  • Resolved Babak Fakhamzadeh

    (@mastababa)


    My site is in Portuguese. In the backend, when editing a form there are five configurable messages under “Configurable messages”. Two of those are shown in Portuguese, three are in English.

    When I create a form and sign up, I see a message saying “Thank you for subscribing. Check your email for the confirmation message.” (in English). This text should be in Portuguese. It is not in the list of ‘configurable messages’.

    I can of course change those configurable messages myself, but I also need that confirmation message to be in Portuguese.

    How to make this happen?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hi @mastababa,

    I commented on your other ticket as I think these issues are related. Let me know there: https://wordpress.org/support/topic/cant-set-a-form-to-single-opt-in/#post-11611730.

    Thank you,
    Kevin.

    Could this not simply be because the translation file is missing?

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hi @mastababa,

    The reason I thought this was a JS error was because you said the message was not in the list of configurable messages. The only way the “Thank you for subscribing. Check you email…” message wouldn’t be configurable is if a JS error was occurring and causing the field to not be visible.

    Since you’re using single opt-in now, the success confirmation message is called “Success: Single opt-in” and should be configurable.

    Does that make sense?

    I have two forms, one is single opt-in, the other is double opt-in.

    For the form with the single opt-in, the ‘thank you’ message is showing in Portuguese.

    For the form with the double opt-in, the ‘thank you’ message is showing in English in the frontend. For this form, I do have a ‘double opt-in’ field. It’s empty, and shows a placeholder in Portuguese.

    But, I found that if I enter text in the ‘double top-in’ field, this text is shown, in stead of the English text.

    So, this is now essentially resolved, though it does appear you have a bug, here. (That is, the default English message is shown when no text is entered in the ‘double opt-in’ field.)

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Ah, I understand. Sounds like either we’re not setting the double opt-in message up for translation or that string hasn’t been translated into Portuguese by anyone yet. We’ll look into this in our next release.

    The string is available for editing, and the placeholder text is showing in Portuguese. So, the text has been translated. It’s just not picked up when the field is empty.

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Unfortunately the placeholder field and the front end field are defined in two separate places in the code.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.