Support » Plugin: WooCommerce » Not all products showing in category pages

  • Resolved petebm

    (@petebm)


    Hi

    May apologies if this has been solved elsewhere, but I’ve been unable to track down an answer.
    For some reason, not all products in our shop categories show up on category pages. For example, as you can see, the link shows 9 products in the Bearings category, whereas the Category view from the admin panel (https://imgur.com/S1CaQFk), and the product export file (https://imgur.com/O4sSN2d) both show 30 items. Taking one of the missing ones as an example, SKU 6502, if you search for it, it comes up, & shows bearings as its category (https://imgur.com/mf2lOYp); looking at visibility etc, all seems OK (https://imgur.com/Q5trmDd).

    This is happening in all categories; I have tried deactivating any product search plugins, and looking for any common elements in missing products – no joy.

    Any pointers to what might be causing this would be much appreciated!

    Thanks
    Pete

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Jess – a11n

    (@jlundie)

    Hi @petebm

    Sorry you’re running into that issue with your category page! As a first step, could you go to WooCommerce > Status > Tools and run *Regenerate* for the Product Lookup Tables?

    Let us know if that does the trick!

    Thread Starter petebm

    (@petebm)

    Hi (@jlundie)

    Many thanks for your suggestion; apologies for the time to reply . . .

    I ran the Regenerate tool, and got the message ‘Lookup tables are regenerating’, so left it doing that for, well, hours in the end, as it said it might take some time. However, I then looked at ‘Scheduled actions’ and found that it had in fact completed in a minute or so! Or at least there were 12 completed actions at the time I started it.
    However, that didn’t seem to cure the problem, so I read around a bit & found a suggestion elsewhere to run the other tools, including updating the database, which it said was scheduled to run in the background, but which I can’t see any sign of in the ‘Scheduled actions’ tab.

    The final upshot, though, is that the problem seems to still be there.
    Sorry!

    Pete

    Thread Starter petebm

    (@petebm)

    Hi

    An update on this. Thanks to the efforts of the support people at YummyWP, who I contacted about a slightly different issue which I thought was to do with their Smart Woocommerce Search, it’s been shown that the problem lies in a confusion over In stock & Out of stock in the database. This itself derives from an issue with integration with Zoho Inventory.

    The cure seems to be to mark a missing product as Out of stock (they all currently show as In stock in a product export), update it, then mark it as In stock and update it. It then magically appears in the product category page as it should.

    Hooray!

    However (aargh!) the problem I now have is that I don’t seem able to achieve the same effect by exporting a product, changing the Stock setting, re-importing, then changing it back in the csv & re-importing again, which I would have assumed would do the same. It doesn’t, which would mean that I’d have to do every ‘missing’ product individually.

    Any suggestions for enabling a bulk solution, please?

    Thanks

    • This reply was modified 2 years, 2 months ago by petebm. Reason: Edited to point out that there was no issue with the Search plugin!
    • This reply was modified 2 years, 2 months ago by Yui.
    Plugin Support Jess – a11n

    (@jlundie)

    Hi Pete,

    I’m so glad you were able to figure out what’s causing that issue!

    Any suggestions for enabling a bulk solution, please?

    Import / export was a great idea. Sorry to hear that didn’t work as expected.

    The next thing I’d test is the bulk edit action:


    Link to image: https://d.pr/i/PYjBet

    I believe that adjusting the In Stock? setting that way should be functionally equivalent to making that change on each individual product page.

    Let us know if that does the trick!

    Thread Starter petebm

    (@petebm)

    Hi @jlundie

    Many thanks for the suggestion; I’m afraid I don’t know what the image was in your last post as the link times out, but I used a bulk edit plugin to make the change – & I now have all the products showing!

    Great, thanks.

    Now for a follow-up question, if I may? Product visibility: I’m sure I’ve set that in the past by just setting the Visibility option on the standard WC import routine to visible or hidden, but when I last tried this it had no effect, and I found I had to change the tax:product_visibility setting shown by a differet export plugin to exclude-from-catalog|exclude-from-search.

    Any ideas why this might be?

    Plugin Support Jess – a11n

    (@jlundie)

    Hi Pete,

    Not sure why my image wouldn’t have come through, but I’m so glad to hear bulk edit did the trick!

    As far as I know, nothing should have changed in terms of the default importer and the Visibility option.

    Could you let us know what version of WooCommerce you are on as well as which other export plugin you are using that is handling this with the tax:product_visibility setting?

    Thanks!

    Thread Starter petebm

    (@petebm)

    Hi @jlundie

    Many thanks again for your continued help – & patience! As you will have gathered, I’m not exactly the world’s best WP/WC problem-solver!

    I’ve now managed to sort out a routine for unscrambling the issues generated by the Zoho sync, which involves deleting affected products, re-importing them from a pre-sync backup, re-syncing, then marking the appropriate products hidden.

    To answer your questions, WoooCommerce is on 2.4.0, and the plugin that I am finding very useful is https://wordpress.org/plugins/pw-bulk-edit/; the tax:product_visibility setting came from https://wordpress.org/plugins/product-import-export-for-woo/, though I’m not using it any more as the bulk edit now does seem to be working for setting the hidden status. I’d thoroughly recommend both – and WooCommerce, of course!

    I’ll try & leave you in peace for a while now.

    Pete

    Plugin Support Jess – a11n

    (@jlundie)

    Hi Pete,

    Happy to help out here! I’m glad to hear that bulk edit is working for setting the catalog visibility setting.

    You may be seeing some weirdness on your site because the version of WooCommerce you are on is seriously outdated (2.4.0 was released in 2015). If you’ve updated your other plugins but not updated WooCommerce, that can cause a variety of unpredictable and unusual behavior.

    Going forward, I’d recommend:

    1. Take a full backup of your site
    2. Update all plugins other than WooCommerce to their latest versions
    3. Update your theme files to the latest version / ensure they have support for the current version of WooCommerce
    4. Update WooCommerce core to the latest version

    Definitely reach out if you run into any other questions!

    Thread Starter petebm

    (@petebm)

    Oh, good grief! What a typo!

    WooCommerce is on 4.2.0! I do try to keep it up to date . . .

    Plugin Support Jess – a11n

    (@jlundie)

    Oh good! I’m so glad to hear that 😄 You should be all set to go then!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Not all products showing in category pages’ is closed to new replies.