Support » Plugin: Migrate WordPress Website & Backups - Prime Mover » Not all images subsite are migrated

  • Resolved Rosanne van Staalduinen

    (@rosanne-van-staalduinen)


    We have migrated a subsite to a single site. All the images in the /wp-content/year/month folders are migrated. But there are also a lot of images in the /wp-content/sites/ID/year/month/day/ folders and those aren’t transfered.

    I can do this manually, but then they won’t show up in the media library. I’m just wondering why the images in the /sites/ folder weren’t migrated. Did I miss a setting?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Codexonics

    (@codexonics)

    Hello Rosanne,
    Thank you for using Prime Mover! Since you migrate from blog ID: 2 of subsite to single site. Prime Mover will only copy all media files from /wp-content/uploads/sites/2/ to your target single site /wp-content/uploads/ directory. It won’t copy files from other blogs or main site because it does not belong to blog ID 2.

    Probably this is a caching issue at your single site after migration. Are you using a cache plugin? Please try purging the cache plugin and see if it resolves the issue.

    Are you also using a page builder plugin? If you are using a page builder- refer to it’s documentation on clearing the cache or assets. For example in Beaver Builder – this is the procedure to clear it. In Elementor this is found in Elementor > Tools > Regenerate CSS.

    If the issue persist after clearing all cache and you still need technical assistance – please send us the following:

    • Your source subsite URL.
    • Your target site URL.
    • Go to your subsite admin dashboard -> Go to Tools -> SiteHealth -> click “Info” click “Copy site info to clipboard” and paste it to text file and label it with filename “source.txt”.
    • Go to your target single site admin dashboard -> Go to Tools -> SiteHealth -> click “Info” click “Copy site info to clipboard” and paste it to text file and label it with filename “target.txt”.
    • Sample list of image URLs in your subsite where it does not exist in your target site after migration
    • [optional but recommended] – please share us the link to download WPRIME package (you can via Gdrive) that you use to migrate to single site. We will use this to reproduce the missing images issue in our local

    Please send us all info via our contact form or via admin dashboard -> Prime Mover -> Contact Us. Thanks!

    Thread Starter Rosanne van Staalduinen

    (@rosanne-van-staalduinen)

    Thank you for your quick reply!

    I have deactivated the specific site in the multisite environment but it’s still there. If I look at the files (FileZilla) from the multisite environment and the single site environment I see that not all images are there.

    If it does work as you explained than this link: https://bulktech.nl/wp-content/uploads/sites/2/2019/05/chemische-processen-innovaties-.jpg should now be https://bulktech.nl/wp-content/uploads/2019/05/chemische-processen-innovaties-.jpg

    But both links doesn’t work. The images is just not there. I will send the requested info via the admin dashboard. Thanks!

    Plugin Author Codexonics

    (@codexonics)

    Hi Rosanne,
    Thanks for feedback. We have replied to your bug ticket in our system with the solution. The latest beta version should fix this issue. Please mark this ticket as resolve if you don’t anymore need technical assistance. Cheers.

    Thread Starter Rosanne van Staalduinen

    (@rosanne-van-staalduinen)

    The beta version has indeed solved the problem. Very nice. Thanks for your quick response and solution. Really fantastic!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.