Support » Fixing WordPress » Not all category posts are displaying on front page

  • Resolved depiction

    (@depiction)


    Hello,

    I just recently upgraded to WordPress 2 from 1.5. Since the upgrade the posts from all categories are not appearing on the front page of the blog.

    I am using two categories. If I make a post with the Category general, it will not appear on the front page of the blog, It will appear under the category. If I make a post with category general and photo, it will appear on the front page. If I make a post with category photo, it will appear on the front page.

    How do I get it so that the latest posts appear on the front page, regardless of category?

    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Could someone help me?

    I doubt it, without more information.

    Theme?
    Post a link?
    Post any conditions used in your loop?

    I prefer not to give a direct link to the blog since it is a family blog that is password protected. If it is really needed, let me know.

    I’m using the Easy White theme from http://themes.wordpress.net/columns/2-columns/877/easy-white-v4/

    The following code in my theme on the index page is what is used to show blog entries:

    [code]
    <?php if (have_posts()) :?>
    <?php $postCount=0; ?>
    <?php while (have_posts()) : the_post();?>
    <?php $postCount++;?>
    <div class=”entry entry-<?php echo $postCount ;?>”>
    <div class=”entrytitle”>
    <h2>” rel=”bookmark” title=”Permanent Link to <?php the_title(); ?>”><?php the_title(); ?></h2>
    <h3><?php the_time(‘F jS, Y’) ?></h3>
    </div>
    <div class=”entrybody”>
    <?php the_content(‘Read the rest of this entry »’); ?>

    </div>

    <div class=”entrymeta”>
    <div class=”postinfo”>
    <span class=”postedby”>Posted by <?php the_author() ?></span>
    <span class=”filedto”>Filed in <?php the_category(‘, ‘) ?> <?php edit_post_link(‘Edit’, ‘ | ‘, ”); ?></span>

    <?php comments_popup_link(‘No Comments »’, ‘1 Comment »’, ‘% Comments »’, ‘commentslink’); ?>
    </div></div>
    [/code]

    Please explain what you mean by loop. What code am I looking for and in what file?

    That was it.. (if, while, endif). I don’t see anything putting conditions on categories…

    Anyone else have any ideas?

    I still haven’t found a solution.

    I can only offer two quick suggestions:

    1)It may be a Parent/Child category issue. WP displays these differently.
    2)You could try using the query template tag to pull the results you need onto the home page of your blog. Then you could specify, the exact category, no. etc… before your loop.

    Finally, if those don’t work, use http://www.pastebin.ca to put your entire index.php onto and place on the this forum. Your template shouldn’t contain any private data? Anyhow, you can always set this to “expire” on pastebin after a few days if that’s still an issue.

    Good luck.

    Using query tags worked.

    Glad to help. Try posting a little more information if you can in the future, as it may help to get your problem solved sooner 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Not all category posts are displaying on front page’ is closed to new replies.