Support » Plugin: WP Mail SMTP by WPForms » Not Acceptable Mod_Security error after I hit “Allow”

  • Resolved lovelybrittney

    (@lovelybrittney)


    First I get the notification, “This isn’t verified” so I click on “Advanced” at the bottom and then “go to domain.com”. I continue and then finally get the “ALLOW” screen so I click it and I get this error over and over again:

    Not Acceptable!

    An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

    How do I get around this? Please help.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    That basically means that your hosting company is blocking some kind of requests to their servers (where your site is located).
    So you will need to contact your hosting support team and ask for clarification. That will result in either certain security rule being disabled or (unlikely) the whole mod_security Apache module will be disabled for your site(s).
    There is no other ways around and nothing can be done by the plugin.

    I would suggest insisting on rule disabling. Please mention while talking to them, that you need to allow the site to receive rather long GET requests from Google to be able to send emails using Google API from your site.

    I hope that helps!

    Oh I see. How annoying. But yes, your reply is helpful. Thank you! I’ll give it a try

    I’ve run into the same issue described here. You say it requires action by my hosting company (HostGator). However, if I use one of the other SMTP plugins that supports GMail/OAUTH2 (Post SMTP, WP Mail SMTP Plugin by Mail Bank), when I authenticate I DON’T get the error. They’re using the same OAUTH2 secure authentication. Why does the error occur with WP Mail SMTP when it doesn’t with the others?

    Plugin Author Slava Abakumov

    (@slaffik)

    @fssbob

    That’s the good question, that I don’t have an answer to.
    I will need to investigate this.

    @fssbob We’ve also encountered this problem. Have you come up with an alternative?

    • This reply was modified 1 year, 3 months ago by  sramler.

    @sramler I’ve been using Mail Bank – Mail SMTP Plugin for WordPress. Has worked well, and they seem to be very much on top of any issues. It has one gotcha: unless you purchase their premium version, you should make sure to turn logging off. Otherwise it will populate your database with log entries you can’t use.

    It would be nice to hear news from @slaffik about what he has found with respect to the Not Acceptable Mod_Security issue.

    @slaffik–have you been able to figure this one out?

    Thanks.

    Yep, if it’s not going to get fixed then we might as well move to another plugin for this. Pity. I’ll give Mail Bank a try. Thanks @fssbob for the recommendation.

    Hi.
    Slava, have the same issue with Gmail on hostgator.

    “An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.”

    PS. I installed plugin to try after your presentation on WP Meetup 6 😉
    if i can help you somehow – i’ll try ))
    ready to try change something on gators apache settings.

    JS console:

    /wp-admin/options-general.php?page=wp-mail-smtp&tab=auth&code=4/AAAeYnBUjFOWx6ms91WaGM0OG0Lu_YiNAE9Tb1xIPBIoQ3wDjphTidIzHC9bzF97SCSB1fB1GSXqhx2YdGgvRKY&scope=https://www.googleapis.com/auth/gmail.send#:1

    Failed to load resource: the server responded with a status of 406 (Not Acceptable)

    Plugin Author Slava Abakumov

    (@slaffik)

    Hi @dmzw

    My 1st reply in this topic actually has the solution: disable mod_security or contact your hosting support. This can’t be done in a plugin, it’s a server related issue.

    Hi @slaffik. I think you were going to determine why Post SMTP & WP Mail SMTP Plugin by Mail Bank–which provide similar functionality with OAUTH2 secure authentication–DON’T give this error on the same hosts. Asking a large host to change its configuration is a much bigger task than switching to a competing plugin.

    Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Not Acceptable Mod_Security error after I hit “Allow”’ is closed to new replies.