Support » Fixing WordPress » Not Able to Save Custom Menu Selection?

  • Resolved fleetadmiralj


    OK, I’ve had some problems with WordPress saving the menu selection before, but nothing to this magnitude.

    Here are the basics:
    – I’m running the Twenty Ten theme, using a child theme (both CSS and some of the design files are changed
    – The theme I’m using is new, but is very similar (only 3 or 4 style changes) from another template I’ve used and I know the menu works on
    – I can create custom menus and save changes to the custom menu. However, if I try to select what menu to use under Appearance -> Menu -> Theme Locations, the “save” doesn’t stick. It doesn’t update on the site (even after clearing cache) and if I go to another page and then go back to the Menu page, the menu is no longer selected.
    – I have tried deactivating all plugins and trying it. That didn’t fix it.
    – I have tried creating another menu, as well as trying on another browser. It still didn’t work.

    Like I said, I’ve had issues with the menus before, though that was usually limited to selecting a menu, and then having it mysteriously get unselected at some later time, but I was always able to just select it again.

    I just have no idea what are causing these menu issues (especially this latest one) and it’s becoming rather irritating. Does anyone have any idea what might be causing this behavior?

Viewing 5 replies - 1 through 5 (of 5 total)
  • OK, I changed the child template to one I had created before, added the menu..and it worked. Switched it to another child template, the menu choice disappeared, but it seemed to stick when I selected again (now that I remember, I think this was the problem with the menu before – it would get wiped out when I changed the theme). Switched to the new template…menu won’t stick.

    I may try just wiping out the template and trying again, though I don’t really know why it won’t work with this child template I made today.

    OK…more into the deep bowels of the database, because I wanted to see what it was doing, both when it worked (using another theme) and both when it wasn’t. As far as I can tell….nothing is different.

    in wp_##_terms, it has:
    term_id: 6
    name: Main Nav
    slug: main-nav

    in wp_##_taxonomy, it has:
    term_taxonomy_id: 6
    term_id: 6
    taxonomy: nav_menu

    (at first I thought the taxonomy name of nav_menu vs. the slug main-nav might be the problem, but it didn’t cause a problem when showing the nav on the template that worked)

    in wp_##_options, under mods_the_long_theme_name it has:

    so it appears to be using the right nav (note i:6, which changed when I at least attempted to select the menu), so it appears to be updating things in the database just fine. It just…isn’t working.

    I haven’t changed anything in the header, and the header.php file this in it:

    <?php wp_nav_menu( array( ‘container_class’ => ‘menu-header’, ‘theme_location’ => ‘primary’ ) ); ?>

    (but it’s obviously working since it worked when I used another theme).

    Again…any ideas why just creating a new theme would blow it up?

    oooooooook. I think I figured out the problem. I haven’t confirmed it in the sense that I 100% know this is the reason, but this is what fixed it:

    I think the “long description” for my theme (ie the thing I put in the style.css file after “Theme Name:”) was too long.

    One thing I noticed was that in the db cells which said what menu to use – the mods_the_long_theme_name items, the theme name I was using was getting truncated, so it was like “mods_a_really_long_theme_na” When I changed it so that the whole thing fit….the menu worked.

    Hi mate,

    i had your same problem, and i used your solution. I changed theme’s name and it worked. Thank you for your post 🙂

    Hi having the same issue, my menu has lots of list items and need to be added more, what happening is I can neither delete nor add a menu item, i.e I delete an item or add but when I try to save page goes blank in Firefox, and displays the following error in Chrome The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.
    Theme: Twenty Eleven,
    Plugins: all deactivated;
    WP version: 3.3.2

    I would appreciate any help, sorry for repeat the same question, I could not find answer in the above discussion

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not Able to Save Custom Menu Selection?’ is closed to new replies.